Trisquel 9 hung even on boot

15 replies [Last post]
lcotton
Offline
Joined: 10/27/2018

Hi

I recently upgraded from Trisquel to Trisquel on my Thinkpad ts 400.

It was running OK when it suddently hung, the keuboard was unresponsive. I tried to reboot (by power cycling), but it also hangs.

Pressing Shift-ESC to try to go to safe mode I see an initial error:
Failed to start light display manager
.....

Then at the end
A start job is running for Hold until boot process finishes up

with a timer.
I have been unable to get to any prompt

On one boot I selected 'Load test configuration' which came up hung again only this time with the message:
'Failed to map dmar2'

If I leave this for long enough it goes back to the 'Failed to start light display manager' error.

Does anyone seem this issue before ?
Does anyone know what might be causing this ?
Does anyone know how I might get to a command prompt in any way ?

lcotton
Offline
Joined: 10/27/2018

Additional question:
I have libreboot on my machine - would anyone know how I can change the boot sequence with that ?

(since it's looking like I'll have to boot from a live usb stick to see what is going on here)

Magic Banana

I am a member!

Offline
Joined: 07/24/2010
strypey
Offline
Joined: 05/14/2015

FYI the problem with lcotton's Thinkpad ts 400 also sounds quite similar to the problem I had with my x60. I was able to get back into a normal Mate session using the solutions reported here:
https://trisquel.info/en/forum/x60-hanging-after-entering-disk-encryption-password#comment-157237

lcotton
Offline
Joined: 10/27/2018

Thank you for the reply

The issue I am seeing does seem similar and I have seen other posts which seem to have the same symptoms as I have. However all solutions I have seen assume that it is possible to get to a login prompt or a terminal.

So far I have been unable to get to one.
Shift-Esc gives me the message:
A start job is running for Hold until boot process finishes up ()

Alt-F2 simply gives me a blank screen

Any idea how I might get to a login prompt ?
Do you know how I can boot in to single user mode (no gui) ?

If all else fails I was hoping to boot from a live puppy usb stick, but at the moment it will not boot from USB - with BIOS I'd have to set the boot sequence to boot from USB first, do you know how I can do that with libreboot ?

The only thing I seem to be able to do at the moment is get to the grub prompt (which may allow me to boot in to single user mode ?)

lcotton
Offline
Joined: 10/27/2018

Just before I left this morning I managed to find an option to boot in rescue mode.
I did so an got to a prompt, so when I get some time I'll try the solutions from some of the posts that seem to relate to a similar issue.

Still be very good to know how to setup libreboot so it'll try to boot from a usb stick before using the hard drive.

lcotton
Offline
Joined: 10/27/2018

Ok. It was but a bit of a struggle getting a network connection, but I finally managed to boot in to recovery mode and get a network connection. Doing the steps in this link:

https://trisquel.info/en/forum/update-90-libreboot-now-computer-wont-boot-gui#comment-154973

Now allows me to boot OK, so thank you for that link.

Doing this I have noticed that my libreboot is not picking up a bootable usb stick, which means at the moment I cannot do a fresh install.
Does anyone know how I can get libreboot to boot from a usb stick ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

The post in question starts with this sentence:
I succeeded with doopon's approach WITHOUT a fresh install.

That said, you certainly want to be able to boot a live system, even if not for that problem. I do not have a Libreboot.

Geshmy
Offline
Joined: 04/23/2015

https://libreboot.org/docs/gnulinux/grub_cbfs.html
https://libreboot.org/docs/gnulinux/grub_boot_installer.html
https://trisquel.info/en/forum/how-do-i-change-boot-order-so-my-libreboot-boots-first-usb-drive

"Doing this I have noticed that my libreboot is not picking up a bootable usb stick, which means at the moment I cannot do a fresh install."

So are you doing this? (From that last link)

'So far, I've discovered that tapping F5 while the machine is booting sends me to a menu with these options:

Load Operating System
Parse ISOLINUX menu (ahci0)
Parse ISOLINUX menu (USB)
Parse ISOLINUX menu (CD/DVD)
Switch to grubtest.cfg
Search for GRUB configuration (grub.cfg) outside of CBFS'

I ask because the "Parse ISOLINUX menu (USB)" option ties in to this link:
https://libreboot.org/docs/gnulinux/grub_boot_installer.html

I copied and pasted some of that page:

"Booting ISOLINUX Images (Automatic Method)

Boot it in GRUB using the Parse ISOLINUX config (USB) option. A new menu should appear in GRUB, showing the boot options for that distro; this is a GRUB menu, converted from the usual ISOLINUX menu provided by that distro.
Booting ISOLINUX Images (Manual Method)

These are generic instructions. They may or may not be correct for your distribution. You must adapt them appropriately, for whatever GNU+Linux distribution it is that you are trying to install.

If the ISOLINUX parser or Search for GRUB configuration options won’t work, then press C in GRUB to access the command line, then run the ls command:

grub> ls

Get the device name from the above output (e.g., usb0). Here’s an example:

grub> cat (usb0)/isolinux/isolinux.cfg

Either the output of this command will be the ISOLINUX menuentries for that ISO, or link to other .cfg files (e.g, /isolinux/foo.cfg). For example, if the file found were foo.cfg, you would use this command:

grub> cat (usb0)/isolinux/foo.cfg

And so on, until you find the correct menuentries for ISOLINUX.

For Debian-based distros (e.g., Trisquel, Devuan), there are typically menuentries listed in /isolinux/txt.cfg or /isolinux/gtk.cfg. For dual-architecture ISO images (i686 and x86_64), there may be separate files directories for each architecture. Just keep searching through the image, until you find the correct ISOLINUX configuration file.

Now, look at the ISOLINUX menuentry; it’ll look like this:
kernel /path/to/kernel append PARAMETERS initrd=/path/to/initrd ...

GRUB works similarly; here are some example GRUB commands:

grub> set root='usb0'
grub> linux /path/to/kernel PARAMETERS MAYBE\_MORE\_PARAMETERS
grub> initrd /path/to/initrd
grub> boot

Note: usb0 may be incorrect. Check the output of the ls command (in GRUB), to see a list of USB devices/partitions. Of course, this will vary from distro to distro. If you did all of that correctly, then it should now be booting your USB drive in the way that you specified."

I don't have libreboot either but this looked like good information and I thought it might provide clarity for instance you can say at exactly which step the process breaks down, what happens vs what the expected outcome was, etc.

If you can download and create a bootable usb (instructions on this same page), there is a netinstall image (trisquel-netinst_9.0_amd64.iso) you might like for a fresh install.

Hope this helps somehow.

lcotton
Offline
Joined: 10/27/2018

Thank you very much for this reply.

Unfortunately when I press F5 I do not see any new options - I've also tried F2, F12, F10, , but to no avail.

I can, however, get to the grub command line and now I am in I guess i can edit grub.cfg directly.

I do not yet know anything about grub and am not too hot on the boot process in general so I will need to find some time to play about with this.

> there is a netinstall image (trisquel-netinst_9.0_amd64.iso) you might like for a fresh install.
Yes I this is another option - but again I'd need to be able to tell the bootloader to use the NIC for boot (as opposed to the hard drive).

It may that if I made the hard drive non-bootable (I think I can do that using fdisk) it would then automatically go to usb, but I don't really want to have to do that every time I want to install a new OS.

Geshmy
Offline
Joined: 04/23/2015

I think you are able to get to grub because the hard drive is bootable. Is that right?

If so, and you used fdisk as you propose assuming 'it would then automatically go to usb' and that doesn't happen, seems like you might be out of options. I wouldn't recommend it.

Here is a link with an idea how one might eliminate the "Failed to map dmar2" message:
https://bbs.archlinux.org/viewtopic.php?id=205008
(But libreleah says that message is benign)

"After hours of trial and error, I figured out that booting with intremap=off in GRUB causes the error to go away. (Error: Failed to map dmar2}"

Does this link explain how you are getting to rescue mode?
https://ostechnix.com/how-to-boot-into-rescue-mode-or-emergency-mode-in-ubuntu-18-04/

If so try the,
mount -n -o remount,rw /

then you can access the logs
do "less /var/log/kern.log"
maybe "less /var/log/boot.log" (may need sudo)
"less Xorg.0.log"

also
https://linuxconfig.org/howto-mount-usb-drive-in-linux

maybe if you can mount a usb in rescue mode then perhaps you can tell grub to boot a Trisquel live image burned to the usb.

One final thought,
re: "but again I'd need to be able to tell the bootloader to use the NIC for boot."

I don't think it works that way, netinstall is an iso too (downloaded and burned to media) so you have to be able to boot to USB or CD or DVD. Its very minimal, lets you setup keyboard, time, network and partitions then it handles download and install of the rest of the OS from there.

I have a PC I am ready to migrate to Trisquel 9. Maybe I'll do that today and do net install.

lcotton
Offline
Joined: 10/27/2018

Thank you for the reply

> Does this link explain how you are getting to rescue mode?
Indeed it does!, though for me it was trial and error and random key strikes before I realised pressing the escape key brought me to the 'Advance options' which then allowed me to select rescue mode.

I have started to look at grub and notice that the grub.cfg is a script that does include Advanced options as a submenu, but before I get to that there is another menu with various options (one of which looks like it might be for usb but isn't - or at least does not detect anything) - I have to press 'o' then ESC to get to advanced options submenu. Not sure where this other menu comes from - it might be part of grub.cfg, but it may be coming from something else that is loaded before that.

The grub.cfg in /boot/grub is different to the one on the ROM - I got the laptop from Technoethical and assume the .cfg was written by them.

I did find this link:
https://www.linuxjournal.com/content/libreboot-x60-part-iii-modify-boot-menu
That gives some instructions both on how to get the version of grub.cfg in the rom and suggests how I might add instruction to install from usb by adding something like:
menuentry 'Parse puppy ISOLINUX menu (USB)' {
label puppy
set root='usb0'
syslinux_configfile -i (usb0)/isolinux.cfg
}

To the grub config file. I have tried this and when I put it at the top it does try to execute this, but all I get is a message 'Install stalled'.

Also I cannot seem to get it stop and provide my additions to the grub.cfg as menu options - I can put them at the top and the first one gets grabbed, otherwise I go straight to default (hard drive) very quickly. If I set timeout to -1 it goes straight to 'Advanced options')

Still grappling about in the dark a bit with this at the moment - It seems I will have to become acquainted with the boot sequence and grub config syntax/scripting to understand it.

I have not tried the rescue mode/usb mount yet, so will give that a go.

I suspect also that I may be able to put an install iso on the hard drive on a separate partition and point grub to that - but again wold need to gen up on grub config for that. Even so would still be good to know and more convenient to simply boot from USB.

> One final thought,
> I don't think it works that way, netinstall ....
Ah. think I got the wrong end of the stick on that one! Thought you meant pointing the booter at the NIC and doing an install pxeboot style.

Geshmy
Offline
Joined: 04/23/2015

lcotton, glad your still with us!

I did install Trisquel-mini to my PC.

Seems funny that I went through the steps to create a bootable usb only to discover my bios present no path to usb drives at all.

So I burned the Trisquel 9 netinst.iso to a cd and went with that, twice in fact and was unhappy with the results both times though I think I made a different mistake each time. First time I arrived at the opportunity to select options like mail server and ssh server to be installed along with a desktop environment. I didn't realize the selection process was to toggle a selection to the 'selected' state with the space bar. Instead I hit enter and the opportunity simply vanished and we raced on to complete the basic install. I did get an openbox desktop working (using apt) but thought I might as well do it over. The second time I selected postfix, lxde and trisquel-mini. Maybe I should have chosen 'mini' or lxde but not both. There were a lot of things that had to be fixed. I threw in the towel when I double clicked on a text file and it tried to open it in gimp.

So installed a third time using the same trisquel-mini dvd I had used to install on my laptop.

The second install took a long time to boot. systemd-analyze showed some 40 seconds + 3+ minutes in user space.

One thing I uncovered was problems with mtrr. This was noticed in all three installs. Apparently something added to the recent kernels.

I found I could edit a line in /etc/default/grub to this:
GRUB_CMDLINE_LINUX_DEFAULT="enable_mtrr_cleanup mtrr_spare_reg_nr=1 mtrr_gran_size=128M mtrr_chunk_size=128M quiet splash" and that totally fixed that problem.

To boot on grub to single user mode:
https://askubuntu.com/questions/132965/how-do-i-boot-into-single-user-mode-from-grub
I'm pretty sure I could also add 'single to the end of the the above line to make it permanent, not that that is wanted.

Well third time was the charm. Am very happy with Trisquel 9 on my PC now and bootup is reasonably quick. Third install shows "Startup finished in 5.833s (kernel) + 55.839s (userspace) = 1min 1.673s
graphical.target reached after 19.806s in userspace." apt-daily.service is the big offender at 34.275 secs according to systemd-analyze blame.

>I recently upgraded from Trisquel to Trisquel on my Thinkpad ts 400.
Doesn't that have a DVD+/-RW?

https://askubuntu.com/questions/174626/how-do-i-burn-a-dvd-iso-using-the-terminal
There is mention of bashburn and I checked, its in our repository.

lcotton
Offline
Joined: 10/27/2018

Thank you again for the extensive reply.

I finally had some success in getting it to pick up from a USB stick.
I plugged in the usb stick then booted and selected to go in to the grub prompt.
There, typing 'ls' gave me a list of the hard drives (and crucially) the syntax it would recognise to access them.

My usb stick came up as (usb0,msdos1), so I added the following to my grub.cfg:
menuentry 'Parse puppy ISOLINUX menu (USB)' {
label puppy
set root=('usb0',msdos1)
syslinux_configfile -i (usb0)/isolinux.cfg
}

Rebooting this was now included in my Advanced menu.
When I selected this entry it booted my puppy into RAM.
At least now I have some hope if I brick the machine and I presumably I can use a similar method to install a new Trisquel on to the hard drive if required.

I still haven't got round to understanding where my top-level boot menu is coming from - will need to get a better understanding of the boot process for that.

> To boot on grub to single user mode:
Ah. Thank you for that link - I'll give this a go. It may be worth adding an option for it to my grub menu - not sure if/how it differs from rescue mode.

>>I recently upgraded from Trisquel to Trisquel on my Thinkpad ts 400.
> Doesn't that have a DVD+/-RW?
Yes it does, so burning to CD and booting from that is an option - though I prefer to do it from USB.

lcotton
Offline
Joined: 10/27/2018

It seems I was a bit premature in thinking that my puppy entry above was working.
It worked once, but when I tried again and since it gives me the Mass storeag stalled error.

If I go in to the grub prompt (boot and press 'c' at the boot menu) I can type 'ls', it gives me (along with the other drives) (usb0,msdos1).

However when I type:
> ls (usb0,msdos1)/
it clearly tries to access the usb stick, but comes up with the error:
'error: USB Mass storage stalled'

Does anyone know what means or what might be causing it ?
Given I did see this work once it may be that my playing around installed something that needs installing to access the usb.

(Initially I thought maybe I had somehow corrupted the USB stick, but trying again on another (BIOS) machine it worked fine.)

As an aside - a proper look at the grub I extracted from the from reveled where the main menu comes from - it must run that cfg first, then run the grub.cfg in /boot on appropriate selection. I can also see the functions that search for the isolinux on the USB stick - once I understand why I cannot access mine from grub I assume I can update these to get the isolinux search working for me.

Geshmy
Offline
Joined: 04/23/2015

I admire your fortitude, I would (and I did) install from a CD or DVD at the first snag but hopefully your efforts will acquire for you some real nugget of understanding.

Its been hard so far to find much searching for that specific error.

At https://www.tenforums.com/drivers-hardware/155277-usb-attached-scsi-mass-storage-device-naming-labeling-error.html I saw an interesting idea but may not relate to what you are finding. These guys are using Windows

One guy reported: "I've just plugged in every single flash drives and external HDD that I have and half are using SCSI while the other half are using USB Mass Storage Device. They're all USB 3.0."

Another responded, "yes. Both external device and usb controller must support the protocol at the same time. In simple words: if the usb controller or the external device don't support it it will be recognized as USB mass storage. If both support it it will recognized as scsi uas."

Another interesting process from https://superuser.com/questions/349633/boot-from-usb-using-grub
(this page might be worth a read)
"The USB device should be detected as a mass storage device and treated just like a hard drive. So, in grub, type 'root (hd' then hit tab once or twice to see what hard drives grub sees."

Other ideas, who knows -
I saw an article from Sony titled 'Computer doesn't recognize the USB connection from a camera'
It mentioned Check the USB cable, USB ports, and memory card
https://www.sony.com/electronics/support/articles/00010619
Maybe it would be be worth trying other flash drives to see how they are seen. Maybe your usb port is wearing out?

I once had a thumb drive that had a tiny little toggle on/off switch.

Good Luck.