Un souci avec Java

2 replies [Last post]
Substance2004
Offline
Joined: 11/05/2013

Bonjour,

Je teste actuellement Freenet. J'ai réussi à me connecter sur le réseau et a surfer un tout petit peu, pas trop de problème de ce côté.

En revanche, j'ai un petit message de Freenet me disant qu'il cessera de fonctionner avec cette ancienne version de Java.

"Votre version de Java 1.6.0_32 est en "fin de vie" et ne recevra plus de mises à jour pour résoudre les problèmes de sécurité. Freenet nécessitera le version $[nouveau} (sic !) ou plus dans une future mise à jour, il cessera de fonctionner avec celle-ci. Merci de mettre à jour très rapidement votre installation de Java."

Je suis passé voir synaptic et je m'y perd un peu.

Je n'ai pas de telle version de Java (la 1.6.0_32)

Le site java.com dit :
"Le logiciel Java pour votre ordinateur ou l'environnement JRE est également appelé Java Runtime, Runtime Environment, Runtime, JRE, Java Virtual Machine, Virtual Machine, Java VM, JVM, VM, plug-in Java, plugin Java, module Java ou téléchargement Java"

J'ai bien Java common 0.43ubuntu2
J'ai même un javasript-common 8 dans les paquets disponible.

Quelqu'un a une idée sur le paquet qui fera l'affaire ???

Je ne sais pas trop lequel choisir...

Merci

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Il te faut le paquet "openjdk-7-jre". JRE signifie "Java Runtime Environment" et les numéros de versions commerciaux enlèvent le "1." (c'est la dire que la version 1.7 s'appelle aussi version 7).

Substance2004
Offline
Joined: 11/05/2013

Merci beaucoup. Avec un nom pareil, je ne l'aurai pas trouvé.

Je ne sais pas si c'est parce que je n'avais pas bien laissé lancer Freenet avant de vouloir y surfer mais là, ça marche...

Le message est toujours sur la page d'accueil, même après avoir redémarré, mais le principal est bien que tout fonctionne...