Update issue

6 replies [Last post]
biosprob
Offline
Joined: 10/10/2015

Tried to do an update of my system and received this error. No idea what it means

E: /var/cache/apt/archives/linux-image-3.13.0-77-lowlatency_3.13.0-77.121+7.0trisquel2_amd64.deb: subprocess dpkg-deb --fsys-tarfile returned error exit status 2

Any help would be much appreciated.

lembas
Offline
Joined: 05/13/2010

Do you have space in root?df -h

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

Also **sudo synaptic** and then remove all the packages in "status" - "residual config".
Take a look at the logs in /var/logs if you find any huge files there taking your preciousss space and also remove all the old kernels.

lembas
Offline
Joined: 05/13/2010

Best to use gksudo with graphical apps, categorically. So

gksudo synaptic

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

The default launcher actually calls 'synaptic-pkexec'.

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

That's correct Magique B.

https://askubuntu.com/questions/78352/when-to-use-pkexec-vs-gksu-gksudo

Just wanted to confirm that on all distros I used (did a lot of hopping a year or something more ago), I opened always **all* the graphical applications with plain sudo without any issue whatsoever. In fact I still do that and see no reason to change the habit.

lembas
Offline
Joined: 05/13/2010

You're welcome to. But it might not be a great idea to tell newcomers to do alike. They might not like it when their computer becomes unusable. And they probably would blame Trisquel or even GNU/Linux for it.

https://help.ubuntu.com/community/RootSudo#Graphical_sudo