Update trying to fetch from repo not in /etc/apt/source.list

2 replies [Last post]
strypey
Offline
Joined: 05/14/2015

When I do a sudo apt update && sudo apt upgrade, I get these message:

> W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.riot.im/debian stretch InRelease: The following signatures were invalid: KEYEXPIRED 1618443732 KEYEXPIRED 1618443732 KEYEXPIRED 1618443732 KEYEXPIRED 1618443732

> W: Failed to fetch https://packages.riot.im/debian/dists/stretch/InRelease The following signatures were invalid: KEYEXPIRED 1618443732 KEYEXPIRED 1618443732 KEYEXPIRED 1618443732 KEYEXPIRED 1618443732

Yet packages.riot.im does no appear in Software and Sources in the control panel, nor in /etc/apt/source.list

Any idea what's going on here and how I can fix it?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

There indeed appears the key was changed on April 15th: https://packages.riot.im/debian/ contains the key and a backup of the older one.

liberpoolesque
Offline
Joined: 01/07/2020

I guess you want to remove that repository?
If there is nothing relevant in /etc/apt/source.list, did you check for any files in /etc/apt/source.list.d/ that might contain a reference to packages.riot.im?