Uruk GNU/Linux 2.0 (Beta1)

28 replies [Last post]
hayderctee
Offline
Joined: 05/02/2015

In any war or big problems, there are calms between storms. There will be days when we lose faith. Days when our apps, DE, and codes turn against us. But the day will never come that we forsake this project and his community.
hello, my name is Hayder Majid and i'm going to tell you story:
when was begin to working on uruk 2.0 we decided to moving to another DE,so we choose cinnamon DE to make it as the default DE, but unexpected things is happened , because cinnamon is lacked for a lot of accessibility features, so we moved to gnome DE, but as usual, gnome has a lot of bugs and crashes windows (the main feature of gnome shell ) ,so we thing it's like the free software lords punished us for leaving mate DE, because it's never disappointed us in version 1.0, so we returned to our holy DE , with more customization and a lot of features to avoid similarity with trisquel 8.0 , and hoping that punishment will be removed.

today we happy to release uruk 2.0 "lugalbanda" (beta-1) with many features

-based on core trisquel 8.0 "flidas"
-mate DE 1.12
-linux-libre-lts 4.9
-gcc-7
-possibility for installing GuixSD package manager
-possibility for installing rpm packages and installing programs from source using one command
-new customization ( login screen , themes, cursor, background, installer slideshow ...)
-uruk welcome screen
-uruk software center ( uruk GNU/Linux version of Lubuntu software center)
-compatible with accessibility
-fixing a lot of bugs

with more things you will discover it.

your time is come, you will face a lot bugs and you must tell us about it

you can download it from here(32 and 64 bit):
https://sourceforge.net/projects/urukos/files/2.0/Beta1/

happy_gnu
Offline
Joined: 08/06/2017

The best DE is no DE, I suggest you move to i3wm :) loool nah just kidding guys, congratulations for your excellent work. Uruk is awesome.

CitoplasmaX
Offline
Joined: 11/24/2016

i3 It is not recommended for new people in GNU/Linux(-libre).

jules_verne
Offline
Joined: 01/02/2017

I personally struggle with the same issue. Doesn't matter how much I run, eventually I end up going back to mate. It works flawlessly. Other DE's makes me more productive, but mate is just too good. Maybe one day it will be more customizable, so one can work without the two bars easily... Until so, the struggle may persist, at least for myself.

I am happy with Uruk's release. Congrats. I wish you success. Never forsake your project.

Dave_Hunt

I am a member!

Offline
Joined: 09/19/2011

Downloading the beta, now, and will have more to say avter I've had a look at it. Glad you've decided to return to Mate de; accessibility in Cinnamon is not ready.

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

Congratulations, hayder and alimiracle!

Ignucius the Saint blesses your computers, long may they run!

RMS_Ignucius.png
Zem Mattress
Offline
Joined: 05/08/2014

If I ever have to use Windows I'll know who I can confess my sins to.

MD. SHAHIDUL ISLAM
Offline
Joined: 10/15/2015

I am waiting for final release.

Dave_Hunt

I am a member!

Offline
Joined: 09/19/2011

I'm running the beta on my little netbook; it looks nearly finished. Not sure whether I can install onto my Thinkpad that has uefi; Trisquel won't boot on the thing. Interested in learning more about this guix package system the include in addition to the apt defaults.

Zem Mattress
Offline
Joined: 05/08/2014

Have to give congratulations: as an "end user" and novice GNU/linux user, I ran Uruk from bootdisk and was very impressed. Very clean, user friendly. It actually ran better faster than Trsiquel on this old HP laptop I'm using.

Great job guys.

- Zem

MD. SHAHIDUL ISLAM
Offline
Joined: 10/15/2015

I am trying to download. But after 90% that crashing. Net speed slow in Bangladesh. Now I am trying again.

Vanecek
Offline
Joined: 01/18/2015

Hello together,

i tried to download Uruk today and had the problem to do so.

The download crashed very often.

But after several trials, i could download it and must say, that this a wonderful distro and i hope that it will have a future.

Thank you for the nice experience!

vita_cell
Offline
Joined: 07/19/2015

I like LXDE or XFCE4. Openbox it is not bad stuff, but I really hate i3. Does Uruk come with systemd?

vita_cell
Offline
Joined: 07/19/2015

Right now I have a netbook asus 900ha which is 32 bits, I installed Devuan, and it has a bit outdated packages, but works great (based on Debian 8.0 not?). I love Arch, but distros based on Arch without systemd aren't so stable, and it is only x86_64. Arch based distros without systemd need a lot of work. Maybe Void is great consideration, but I don't know what is their philosophy.

Mappack
Offline
Joined: 10/13/2016

FreeSlack 64 works fine for me.

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

>I like LXDE or XFCE4. Openbox it is not bad stuff, but I really hate i3.

wow, are you me? :)

quantumgravity
Offline
Joined: 04/22/2013

Since I tweaked i3 and mastered its usage, I dont want anything else anymore. It's the same with vim.
At first you might think "wtf, who would ever want to use that?" but then you realize that there is nothing better out there.

alimiracle
Offline
Joined: 01/18/2014

try guix sd
its dont use systemd

quantumgravity
Offline
Joined: 04/22/2013

I saw that you have custom tools like u-src for automated building from source. How does the program work? Can people with other distributions use it as well?

alimiracle
Offline
Joined: 01/18/2014

its try to Looking for the appropriate method to build the app
if it find it
Will be used that way.
For example
Some programs
build useing
chmod +x configure
./configure
make
yes you can use it in other distributions

jorgesumle
Offline
Joined: 06/01/2016

When I execute sudo apt-get update I get the following errors or warnings:

W: http://packages.urukproject.org/dists/lugalbanda/InRelease: Signature by key F094C518D6F659B7783F25866B3C79D5138BA0FE uses weak digest algorithm (SHA1)
W: GPG error: http://linux-libre.fsfla.org/pub/linux-libre/freesh freesh InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D0DB31B545A3198
W: The repository 'http://linux-libre.fsfla.org/pub/linux-libre/freesh freesh InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Libremind
Offline
Joined: 06/20/2017

> When I execute sudo apt-get update I get the following errors or
> warnings:
>
> W: http://packages.urukproject.org/dists/lugalbanda/InRelease:
> Signature by key F094C518D6F659B7783F25866B3C79D5138BA0FE uses weak
> digest algorithm (SHA1)
This error is caused by weak digest algorithm (SHA1), SHA256 is recommended, therefore you should report this to uruk developers.

> W: GPG error: http://linux-libre.fsfla.org/pub/linux-libre/freesh
> freesh InRelease: The following signatures couldn't be verified
> because the public key is not available: NO_PUBKEY 9D0DB31B545A3198
You should import the repo public key:

Download the public key from the website
wget https://jxself.org/gpg.inc

Verify the fingerprints of the key
gpg --with-fingerprints gpg.inc

Make sure that you see:
Key fingerprint = F611 A908 FFA1 65C6 9958 4ED4 9D0D B31B 545A 3198

Then add the key and delete the gpg.inc file
sudo apt-key add gpg.inc && rm gpg.inc

Try to update and see if it's resolved
sudo apt update

For more info check the website https://jxself.org/linux-libre/

MD. SHAHIDUL ISLAM
Offline
Joined: 10/15/2015

I am with uruk 2.0. I'm happy with it. But it tooks more ram space than uruk 1.0. my ram = 2 gb. I always prefer 64 bit. Any benefit of 32 bit Os than 64 bit?

vlcsnap-2017-09-06-00h12m25s020.jpg
Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Bravo to the Uruk Team, despite the issues you faced you have done a great job !
Thanks ;-)

MD. SHAHIDUL ISLAM
Offline
Joined: 10/15/2015

mision@vision:~$ sudo apt-get install gnome
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnome : Depends: gnome-core (= 1:3.14+3ubuntu1) but it is not going to be installed
Depends: alacarte (>= 3.11) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What I can I do?

MD. SHAHIDUL ISLAM
Offline
Joined: 10/15/2015

mision@vision:~$ sudo apt-get install cairo-dock
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cairo-dock : Depends: cairo-dock-plug-ins (>= 3.4.1) but it is not going to be installed
Depends: cairo-dock-plug-ins-dbus-interface-python (>= 3.4.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

It alos not installed.
I am now using Uruk 2.0 (Beta 1)

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Hi MD.Shahidul Islam
Try fixing broken packages with synaptic
Synaptic>Edit>Fix Broken Packages

As HayderCtee pointed out in https://trisquel.info/fr/forum/more-xfce-problems#comment-120971

Not just xfce, gnome and many other packages is broken by default in trisquel 8.0, because fildas repository is not complete, so you should download missing packages manually , some times you should download more than 20 packages( I hope Trisquel team will fix this problem )

Best to stick to default Uruk Mate environment for the moment
;-)

MD. SHAHIDUL ISLAM
Offline
Joined: 10/15/2015

So, Trisquel 8.0 or Uruk2.0 is not complete yet.

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Yes, as Uruk 2-beta-2 is based off Triquel (Apha) 8-core there are still packages & dependencies missing, which is why you cannot install Gnome (depends on Gnome-core which is not yet available).