using jxself's Linux-libre to get Radeon's 2D acceleration

5 replies [Last post]
arielenter

I am a member!

I am a translator!

Offline
Joined: 08/25/2010

Hello every body:

I'm trying to use jxself's Linux-libre to get 2D acceleration on my Radeon card, but so far I'm afraid I haven't been able to get it working.

My "lspci | grep VGA" shows this:

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R6 Graphics]

"uname -mrs" shows:

Linux 4.9.0-gnu x86_64

So far what I have try is to commend all blacklist entries as suggested here https://trisquel.info/en/forum/making-radeon-work-again-bringing-back-linux-libre-34#comment-80331

I also made a /etc/X11/xorg.conf.d/20-radeon.conf as suggested here https://trisquel.info/en/forum/making-radeon-work-again-bringing-back-linux-libre-34#comment-80363

While wring this to this point, I found https://trisquel.info/en/forum/problems-amd-screen-resolution . Could it be that I'm on the same page?

I get the right resolution with the vesa driver but I was hopping to get better support.

I'm attaching my /var/log/Xorg.0.log which does have the same two lines from the quoted post:

[KMS] drm report modesetting isn't supported.
(EE) Screen 0 deleted because of no matching config section.
(II) UnloadModule: "radeon"

Maybe I could try "compile a version of libdrm without radeon KMS support" as suggested in https://trisquel.info/en/forum/problems-amd-screen-resolution#comment-55522

Thank you for your attention.

AttachmentSize
Xorg.0.txt107.75 KB
GNUtoo
Offline
Joined: 11/10/2009

Hi,

Could you post the result of the dmesg command, after it tried to start Xorg.

Denis.

arielenter

I am a member!

I am a translator!

Offline
Joined: 08/25/2010

Thanks,

I'm attaching the result of running dmesg, hopefully it will help. Also, could someone tell me how can I find out whether or not I'm using the radeon driver already? I thought that "glxinfo | grep -i vendor" would be enough but I'm not so sure now. This is the result of running that command:

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.

I'm pretty sure I'm not, because I haven't seen any change, but that might also mean I was using radeon all along so I'm not so sure any more. Thank you.

AttachmentSize
dmesg.txt 73.26 KB
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Execute tis command in a terminal:
$ lspci -v
For instance I use the i915 kernel driver:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device 2027
Flags: bus master, fast devsel, latency 0, IRQ 25
Memory at f2800000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities:
Kernel driver in use: i915

GNUtoo
Offline
Joined: 11/10/2009

Also, could someone tell me how can I find out whether or not I'm using the radeon driver already?

This information is in dmesg:

[    2.279343] 0000:00:01.0: Missing Free firmware (non-Free firmware loading is disabled)
[    2.279373] radeon 0000:00:01.0: Direct firmware load for /*(DEBLOBBED)*/ failed with error -2
[    2.279375] 0000:00:01.0: Missing Free firmware (non-Free firmware loading is disabled)
[    2.279389] radeon 0000:00:01.0: Direct firmware load for /*(DEBLOBBED)*/ failed with error -2
[    2.279469] [drm:cik_init [radeon]] *ERROR* Failed to load firmware!
[    2.279476] radeon 0000:00:01.0: Fatal error during GPU init
[    2.279483] [drm] radeon: finishing device.
[    2.287677] [TTM] Finalizing pool allocator
[    2.287685] [TTM] Finalizing DMA pool allocator
[    2.287733] [TTM] Zone  kernel: Used memory at exit: 0 kiB
[    2.287737] [TTM] Zone   dma32: Used memory at exit: 0 kiB
[    2.287739] [drm] radeon: ttm finalized
[    2.288198] radeon: probe of 0000:00:01.0 failed with error -22

Here it failed to load the radeon driver:

 [    2.288198] radeon: probe of 0000:00:01.0 failed with error -22

The "error -22" is "EINVAL" in C.

Here's how to fix it:
https://trisquel.info/en/forum/first-development-alpha-iso-images-trisquel-80-flidas#comment-106872

(From this thread: https://trisquel.info/en/forum/first-development-alpha-iso-images-trisquel-80-flidas)

Denis.

GNUtoo
Offline
Joined: 11/10/2009

So the idea is to first add your GPU in linux-libre: you just need to add it to the list of supported GPU, and most importantly, to test that it works. Then you need to report what you did and if it worked in the linux-libre mailing list.

People might also help you in in that endeavor, like they might or might not make the modification for you for instance.

However at the end of the day you will still need to test if it works, and to report that to the linux-libre mailing list.

Once this is done, it's just a matter of waiting for the new linux-libre kernel to land in jxself's repository, and then it should work (else report at the linux-libre mailing list that it doesn't).

Denis.