Window resizing issue

13 replies [Last post]
knopton
Offline
Joined: 11/11/2015

Hello, I open this topic because my laptop is having an issue already mentioned in this forum but without answer:

http://trisquel.info/en/forum/trisquel-7-rc-resizing-windows-gnome-stops-continues

As the topic is locked, I could not post my answer there. The point is that some windows, mainly from GNOME desktop applications, suffer from a lag when resizing them for the first time. After this lag of 3-5 seconds, the windows are resized instantaneously as the mouse is moved. My OS is Trisquel 7.0 LTS, installed in a Thinkpad X200.

I could first think that the GNOME desktop is too heavy for my old laptop. However, this lag is not shown in other heavy applications which are not part of GNOME (for example, Abrowser). Maybe there is an issue when customizing the GNOME desktop for the Trisquel distribution, as I have not observed this in the GNOME Flashback desktop of an Ubuntu clean install.

Has somebody observed this problem?

Best regards.

knopton
Offline
Joined: 11/11/2015

Sorry for writing this message, but a spammer has written answers in at least 3 pages of this forum and my post, which is recent, has been moved to page 4. I also think that it would be interesting to check that this problem occurs in other laptops and not only in my Thinkpad X200.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Do you run Compton? If so, have you tried tuning /etc/compton.conf?

knopton
Offline
Joined: 11/11/2015

Thank you for your answer. I do not have Compton installed in my computer. My Thinkpad runs a clean installation of Trisquel 7.0, with GNOME 3 Flashback and Metacity. I will give a try to Compton, when I test it I will write about its performance.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

The "compton" package actually depends on both "trisquel" and "trisquel-desktop-common".

knopton
Offline
Joined: 11/11/2015

You are right, Magic Banana, I did not know that Compton is present in a fresh installation of Trisquel 7. Thank you for your support, because this point has actually helped me solve this issue, as well as this link:

http://comments.gmane.org/gmane.linux.distributions.trisquel.user.spanish/10917

It seems that the use of Metacity as the default window manager causes the issue related to window resizing, so my fix was simply to create my own gnome-sessions and xsessions in /usr/share. I created two entries:

- GNOME Flashback + Compiz (my new main session), and

- GNOME Flashback + Metacity (to keep the old session too).

Since I use Compiz as my window manager, the resizing issues have disappeared. I attach the files which I have created, I hope that this may help others with the same problem.

Best regards.

AttachmentSize
trisquel7-window-manager-fix.tar 8.5 KB
vita_cell
Offline
Joined: 07/19/2015

I think that Compiz is a desktop composer, not window manager.

Metacity, gtk-window-decorator...Are window managers.

I never had problems with gtk-window-decorator.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Compiz is, like Metacity, a window manager. The window decorator is a component of the window manager. At least, this is what I understood.

vita_cell
Offline
Joined: 07/19/2015

Compiz = composer + window manager?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Compiz is a "compositing window manager": https://en.wikipedia.org/wiki/Compositing_window_manager

It takes advantage of the "Composite Extension" of the X Window System: https://en.wikipedia.org/wiki/Composite_%28graphics%29

loldier
Offline
Joined: 02/17/2016

I have the same issue on my HP Probook laptop with Intel integrated graphics. The initial lag (in resizing) is a second or two at the most, probably due to my laptop being a bit more powerful.

How do I enable Compiz? I tried 'compiz --replace', won't work (the desktop freezes or window decorations and buttons vanish, also the command in Terminal never exits). I have installed Compiz and CompizConfig Settings Manager.

What am I supposed to do with your attached files? Place them in /usr/share? I tried that, but the sessions could not be launched, so I went back to my backups.

I guess it all hinges on there being no support for 3D acceleration. I added a menu entry in Accessories (Window manager and effects) to enable Compiz but the desktop freezes. On restart Compiz is allegedly back on but not working, so I had to resort to a script mentioned in this thread to get Metacity back by default.

https://trisquel.info/en/forum/compiz-startup

Also, Compiz Fusion Icon doesn't seem to do anything.

SelectWinManager.png
knopton
Offline
Joined: 11/11/2015

You have to copy the files using the same directory tree inside the tar file. Then, reboot your system. When the login screen appears, you will see an icon which allows you to choose between "Trisquel (Compiz)" or "Trisquel (Metacity)".

You do not have to run Compiz in the terminal when the session is already started because your session will get frozen. The Compiz Fusion icon is also not necessary. You just need to have Compiz installed.

If you continue having problems, feel free to ask me again. ;-)

loldier
Offline
Joined: 02/17/2016

Alright. Now I'm rocking. I just copied (in TTY1 as root) everything from '/usr/share/gnome-session/sessions & /usr/share/xsessions' to their respective folders in '/usr/share'. Rebooted but it was a mess because I had autologin on and it froze again. Switched off the computer and restarted and then, voila I had three sessions to choose from (default/compiz/metacity). I suppose I should've deleted the default Trisquel session file but it works as it is. And guess what, now window resizing is silk-smooth no jerks or lags.

Thanks!

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

I would try to activate or deactivate the compositing manager of Metacity (Trisquel's default window manager) an see whether it makes a difference. You can do that from the terminal. To activate the compositing manager:
$ gsettings set org.gnome.metacity compositing-manager true
To deactivate it:
$ gsettings set org.gnome.metacity compositing-manager false

For the modification to be effective, you can log out your graphical session and log in again.