is it possible to re-install just network-manager from orig Trisquel CD

Category:support request
Status:needs more info

I deleted the network-manager package from Trisquel on my hard disk. If its not complicated, can someone tell me how to re-install just it from the CD? I was trying to get rid of a bluetooth app that is installed by default with network-manager... I don't have any bluetooth devices and didn't want related software taking up RAM. I've reinstalled Trisquel several times from scratch, and would like to avoid having to do it again. Thanks for any helpful advice with this.

Thu, 10/09/2014 - 22:08

One method to recover from this situation would be to add the line

iface eth0 inet dhcp

To the bottom of /etc/network/interfaces

reboot, plug your computer in by wired ethernet and use one of the usual install tools to install network-manager over the Internet. Unplug the ethernet, delete the extra line from /etc/network/interfaces then reboot again.

Or you can find any packages you need on , download them to a USB stick on another machine and install them from the command line with

sudo dpkg --install package-file-name

But if you do that you're left with sorting out the dependencies manually.

AFAIK the install CD isn't in an 'apt-cdrom add' compatible format (I haven't tried in years because the early Ubuntu ones weren't) so I'd go for the above methods first.

If these methods fixes your problem, please close / reply to this issue.

Sat, 10/11/2014 - 15:09
Status:active» needs more info
Mon, 10/13/2014 - 06:31

Hello Leny, thanks for replying.
I'd like to try your 1st suggestion, but need to clarify the how:
> to add the line
> iface eth0 inet dhcp
> To the bottom of /etc/network/interfaces

??? In what program? Where? Steps? to find "/etc/network/interfaces"

If my questions indicate this is probably too complicated for my level of know-how, I won't be offended if you say so. If it is more time-consuming to learn what I'd need to know first than reinstalling Trisquel from scratch, I can wait till Trisquel 7 is released, then install it.

Tue, 10/14/2014 - 15:25

It's a system configuration file. You need to be root (superuser) to edit it. The easiest way is to go open Accessories > Terminal and type

sudo gedit /etc/network/interfaces

The password it asks for is your usual login password. When the window opens scroll to the bottom, click on the end of the last line, press enter, then type

iface eth0 inet dhcp

press enter again,

Then Ctrl-S (press and hold control, then press S, release S, release control) to save when you've finished.

Ctrl-Q to exit. You can also use the File menu for these last two.

[edited following]

However, if you're befuddled by editing configuration files, and nobody is saying that's unreasonable. Then first just try plugging it in via a wired connection, it may or may not work depending on exactly what got de-installed. If it doesn't then you might go for the re-install as you know how to do that already rather than the detailed stuff. Your call. Obviously backup your home directory with System Settings > Backups first so you can reload your data afterwards.

Mon, 10/13/2014 - 10:23

>sudo gedit

It's best to always use gksudo with graphical apps. Yes, some will work with plain sudo but some will not and then you've not a nasty permissions mess on your hands.

Tue, 10/14/2014 - 01:52

nano might be better, as it's not graphical but is still intuitive to use.

Tue, 10/14/2014 - 15:18


sudo gedit has worked for years and I retested on Belenos before recommending it. I used it because two words beginning with g might well get transposed as is common and the user might not have the experience needed to spot and correct a command line mistake.


Yes nano is pretty intuitive, but IMO for someone who doesn't know what a /file/path looks like and might not be familiar with the command line gedit is a better bet.

@both - please read my profile - I am your grandmother when it comes to user support. The problem is more that my mind might dredge up something from the 90s or earlier as still current :-).

Wed, 10/15/2014 - 08:54

Thanks for the add'l info Leny2010.
I could understand your original suggestion with this to follow it through. However, after doing it, I still can't connect to the internet at all. I copied my current "interfaces" file - after making the recommended change, I'm including it below in case it reveals to you what else is missing but needed.

"auto lo
iface lo inet loopback
iface eth0 inet dhcp"

Again, if that indicates a complicated fix - too time consuming to explain, feel free to say so.

Sun, 10/19/2014 - 05:28

I haven't had a new reply to my last question and can't proceed with the described method. Just in case, this would lead to an easier solution:
- I still have my Trisquel 6 CD, can I copy just network-manager & its dependencies to my otherwise functional hard-disk version of Trisquel?
OR, if it would help with an easier solution:
- I have Debian 7 and GnuSense also installed, and can access the web with either, they're updated with any network-manager updates available through their repositories.

In other words I already have the complete necessary network-manager package(s) in 2 places on my hard disk... is there a relatively easy way to get Synaptic Package Manager in Trisquel to find & install those packages from my CD or either of the hard disk sources?

Sun, 10/19/2014 - 16:53

It's a matter of downloading the _package_ from here[1], then copying it to your home directory on the the affected machine using a USB stick. Finally installing it by doing the following

sudo dpkg --install network-manager*press tab*

(replace stuff in *these* with the obvious things.) However, if you look at that page[1] you also have to have all the packages with red dots and you will need to sort out any of those first for a successful install. You would normally use

apt-cache policy *package name*

And check the 'Installed:' field. But in the time you do that manually and then again for those which are missing their red dot packages and so on you could install from scratch. So AFTER TAKING A BACKUP try with just the network-manager package using the *dangerous*

sudo dpkg --force-all --install network-manager*TAB*

In the hope just the Bluetooth stuff will be missing. If that fails then move to a fresh install would be my recommendation. If you get networking back, then do a normal

sudo apt-get install *packages...*

for all those packages with red dots to recover your system to a consistent state. But I'll warn you I've only once had success with this method. Yes it's theoretically possible to recover it by downloading all the dependencies as I've described, just as I've indicated, it usually isn't worth it.


Mon, 10/20/2014 - 16:54

Thanks very much Leny2010. It does seem too complicated & time-consuming to just reinstall the network-manager package(s)! So I will just reinstall Trisquel from scratch.

Thanks also:


I do prefer gksudo when I can use some graphical version of a program, to avoid having to know, understand and remember commands... which I usually forget within minutes, or seconds, of using them.


Unfortunately little to nothing is "intuitive" to me when it comes to using commands in a terminal. My memory for such stuff is so poor that I don't even attempt to learn a bunch of commands.

At this point I'm content to consider this issue "closed", but I'll take note if anyone does choose to add add'l replies.