Abrowser font rendering

Project:Trisquel
Version:8.0
Component:Programs
Category:bug report
Priority:critical
Assigned:Unassigned
Status:active
Description

Since the latest update, text occasionally becomes blurry in Abrowser (see attached screenshot). Highlighting the text sometimes causes the selected text to render properly. This problem occurs whether the new privacy setting "Do not load custom fonts" is turned on or off.

AttachmentSize
Screenshot at 2018-02-24 14:32:27.png76.72 KB
Sat, 03/31/2018 - 06:38

After upgrading Abrowser today, this problem persists. While it is not a serious bug, I think it needs to be addressed before the official Trisquel 8 release. One of the first things people will do when trying Trisquel is test the default web browser, and encountering this early on might give the false impression that Trisquel is buggy in general.

Wed, 07/11/2018 - 19:53
Priority:normal» minor

Changing priority to "minor" because it does not seem to affect most users. I suspect it's related to hardware for this reason. However, it is not an issue with regular Firefox, and comparing the default about:config settings for Abrowser and Firefox I don't see anything that could be the cause.

I've tried the solutions in every thread I can find about blurriness in Firefox, and none work. Most solutions are specific to font rendering, which is not the issue because images are affected too. Disabling hardware acceleration seemed promising but had no effect.

I've noticed that the blurriness comes and goes as I scroll. Often, if I scroll down a bit the blurriness will go away, and if I scroll back up the blurriness will return at the exact same point. Moreover, the blurriness never appears until I begin scrolling through a page. This makes me suspect that scrolling might actually cause the issue. However, disabling smooth scrolling had no effect, and I haven't found any other settings related to scrolling that might apply.

Mon, 07/16/2018 - 23:06
Priority:minor» critical

In current Trisquel 32-bit, Abrowser current, Firefox current, and Tor current all exhibit the blurry text on all forum pages and other page types variously.
Seamonkey 2.49.3 does not exhibit this issue.
When the blurry text exists, clicking to another tab and back clears up the section of blurry text. However, scrolling immediately produces blurry text in subsequent sections.
Also, neither Firefox current, Tor current, nor Seamonkey current exhibit these behaviors in LinuxMint.
It is a major issue since internet browsing and communication is a major function performed by my computers, and some of it is conducted using browsers.
Abrowser would be functional for me otherwise, if not for this major issue.
I might suggest editing title to "text consistently blurry in Abrowser."

Sat, 08/11/2018 - 21:25

Hm. I consistently have this problem in Abrowser, but not in Tor Browser, Icecat, or Firefox. Have you tried Icecat?

Thu, 08/16/2018 - 21:20
Title:text sometimes blurry in abrowser» Abrowser font rendering
Wed, 09/05/2018 - 17:39

Hi, I'm having the same problem. As you mention, this only happens with abrowser.
It usually happens in images and text. If I select the blurry image/file with my pointer then It shows well.

AttachmentSize
abrowserblur.png 409.5 KB
Tue, 09/11/2018 - 07:27

Im sorry to hear this . . . how do we fix this bug.

here's my hardware readout >>>>

H/W path Device Class Description
===================================================
system 892229U (Intel)
/0/4 processor Intel(R) Celeron(R) M CPU 420 @
/0/13 memory 3GiB System Memory
/0/100/2 display Mobile 945GM/GMS, 943/940GML Express Int
/0/100/2.1 display Mobile 945GM/GMS/GME, 943/940GML Express
troller

Wed, 10/24/2018 - 11:55

I got absolutely same problem as chaosmonk described. I think it might have some "Hardware Acceleration" linked, but if this doesn't affect I have no idea where it might come.

Wed, 10/24/2018 - 15:29

I updated kernel to linux-libre-4.19-gnu and problem magically disappered.