Upgrading from etiona to nabia

8 risposte [Ultimo contenuto]
Iscritto: 01/03/2015

After getting a Lenovo T430 with Windoze_10 installed, I set about making the 'puter dual boot.
Everything went OK ... well almost OK.The Windoze setup blocked access to the USB ports; I got
around that impediment by installing from a Trisquel_9 Live DVD.

Upgrading etiona to nabia appears to be next to impossible, because my nabia Live flash drive
isn't recognized during a reboot. I have not attempted a foray into the system setup. My effort
is instead concentrated on downloading the Trisquel_10 .ISO image (a mirror change is necessary),
but the Lenovo DVD drive is not getting recognized by the disk-burner software, and even when
that's available, the blank DVD is not getting recognized. The blank-disk recognition problem
is a long=standing one. That Trisquel_9 Live DVD was troublesome as well. Did I mention that
the DVD-burner obstacle is in a pure-trisquel T420 ? I dare not attempt the Windoze-to-Trisquel
route on that T430.

Iscritto: 01/03/2015

Oops; turns out that my stock of blank DVDs have a capacity of 1.9 GB, whereas the .ISO is 2.9GB.
I ordered a supply of the 4.7 GB variety.

The CMOS settings aren't what's blocking the Live flash drive; that's a Windoze_10 function.

Iscritto: 01/03/2015

after acquiring a stack of DVDRW disks, I set about the task of making a bootable
Live Disk of Trisquel_10.0.1amd64. In order to accomplish this task, I first ran
update-grub with the present 1.0TB HDD at /dev/sdb; then I hot-unplugged it and
hot-plugged a DVDRW drive in its place.
Then I resatarted the Thinkpad T420 with a Trisquel_10 Live flash drive, and
selected "Try Trisquel without installing." The Disks function in the Control
Center identifies it as Optiarc DVD RW AD-7710H (1.S0) but says that the media is
read-only. Ejecting the DVDRW disk and re-inserting it doesn't change its read-only
status, even though the disk is plainly marked DVDRW and 12X/4.7 GB.

This has happened before; see:
where it's said by jibgrowisofs -Z /dev/dvdrw=trisquel_9.0_amd64.iso
which I adapted to Trisquel_10: growisofs -Z /dev/dvdrw=trisquel_10.0.1_amd64.iso
:-( /dev/dvdrw:
media is not recognized as recordable DVD: 0 Modifying the command
code>growisofs -Z /dev/sr0=trisquel_10.0.1_amd64.iso :-( /dev/sr0: media is not recognized as recordable DVD: 0.
After reading man growisofs I triedgrowisofs -dvd-compat -Z /dev/dvd=trisquel_10.0.1_amd64.iso
but got the same error: :-( /dev/dvd: media is not recognized as recordable DVD: 0

Iscritto: 01/03/2015

Here's some more information on the dvdrw drive:
Blockdevice: "/dev/sr0"
Vendor: "Optiarc"
Description: "DVD RW AD-7710H"
Version: "1.S0"
Write speed: 4234
Profiles: "DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM,
DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW"
Read Cap: "DVD-ROM, DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R
Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+RW Dual Layer,
DVD+R Dual Layer, CD-ROM, CD-R, CD-RW"
Write Cap: "DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer
Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R, CD-RW"
Writing modes: "SAO, TAO, RAW, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump"

Iscritto: 01/03/2015

After installing wodim, I tried two commands suggested here:

wodim --devices
wodim: Overview of accessible drives (1 found) :
0 dev='/dev/sg1' rwrw-- : 'Optiarc' 'DVD RW AD-7710H'

wodim -vv dev=/dev/sg1 blank=fast
TOC Type: 1 = CD-ROM
wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
scsidev: '/dev/sg1'
devname: '/dev/sg1'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.36
Wodim version: 1.1.11
Using libusal version 'Cdrkit-1.1.11'.
SCSI buffer size: 64512
Device type : Removable CD-ROM
Version : 5
Response Format: 2
Capabilities :
Vendor_info : 'Optiarc '
Identification : 'DVD RW AD-7710H '
Revision : '1.S0'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
wodim: Cannot load media with this drive!
wodim: Try to load media by hand.
Current: 0x0000 (Reserved/Unknown)
Profile: 0x002B (DVD+R/DL)
Profile: 0x001B (DVD+R)
Profile: 0x001A (DVD+RW)
Profile: 0x0016 (DVD-R/DL layer jump recording)
Profile: 0x0015 (DVD-R/DL sequential recording)
Profile: 0x0014 (DVD-RW sequential recording)
Profile: 0x0013 (DVD-RW restricted overwrite)
Profile: 0x0012 (DVD-RAM)
Profile: 0x0011 (DVD-R sequential recording)
Profile: 0x0010 (DVD-ROM)
Profile: 0x000A (CD-RW)
Profile: 0x0009 (CD-R)
Profile: 0x0008 (CD-ROM)
Profile: 0x0002 (Removable disk)
Supported CD-RW media types: 07
Drive current speed: 24
Drive default speed: 24
Drive max speed : 24
Selected speed : 24
Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
Supported modes: TAO PACKET SAO SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
01 00 00 01 00 00 00 00
01 AA 01 01 00 00 00 00
Track 1 start -150
wodim: Cannot load media with this drive!
wodim: Try to load media by hand.
wodim: Cannot load media.

Iscritto: 05/28/2022

Hopefully you can get Trisquel 10 installed eventually. Thanks for sharing about your attempts.

Iscritto: 01/03/2015

With Lappi's encouragement, I pressed on.
Step 1. On a working Thinkpad T420, I hot-unplugged the HDD occupying the CDROM drive slot
and then hot-plugged the T430's DVD-RW drive in its place, followed by sudo upfdate-grub so
grub won't complain about a missing entry on the next restart.

Step 2. Hot-plug the TQ_10 flash drive in an open USB port, and then shut down TQ_10, followed
by a restart, whereupon I could "try trisquel without installing."

Step 3. In the System/Control Center app, select "Disks" whereupon the CD/DVD drive is detected;
its state is "read only" which I safely ignored later on. That's the way a blank DVDRW drive
appears to the 'puter ... it's also called a blank DVD +R disc, which is positive news.

Step 4. Use Brasero to burn the .iso image (stored in a USB-connected 1.8 TB drive) into the
blank DVD +R; this last step is straightforwardly accomplished.

Step 5. Transfer the T430's DVD-RW drive to its slot; insert the newly created Live TQ_10 DVD
and restart the T430, whereupon the familiar Live Trisquel appears; install into the already
existing (but barely functional) TQ_10. This takes a while with much commotion of read-write
steps that can be heard from the DVD-RW drive. I then burned another Live-TQ_10 disk in the
T430 without incident, with the 1.8 TB USB-connected HDD as the source of the .ISO image.

Incidentally, the T430 has only a couple of USB ports; I'm using a Lenovo port extender which
adds four more USB ports. These connections do not have to be re-made when switching 'puters,
so now there are six USB ports when using the T430 and eight USB ports available with a T420.

Iscritto: 05/28/2022

So "install into the already existing (but barely functional) TQ_10" means you got it installed so it runs without a bootable device? Your perseverance is an example for the rest of us!
In your first post on this thread you wrote "The Windoze setup blocked access to the USB ports." Is that normal to happen?
The first Trisquel GNU/Linux I installed was 8. Wondering how to upgrade it to 9 I came across a command(s?) somewhere to do so. From what I remember, I followed the described step(s?), it took quite a while, but when it rebooted it was Trisquel 9.

Iscritto: 01/03/2015

Answering Lappi's questions:

(1) My first installation of TQ_10 had no access to the Thinkpad's USB ports; I could
accomplish that only from a TQ_9 Live DVD and then upgrading to TQ_10, but I couldn't
use the TQ_10 thumb drive, even with TQ_10.

(2) Windows has been an extremely predatory operating system in my experience. Windoze
10 took control of the USB ports, blocking Trisquel's USB Flash drive. My clumsy attempt
at one website's workaround only made matters worse. Trisquel's Live DVD regained control
of the USB ports and recognized the T430's DVD-RW drive as well, so grub works fine,
listing both the Windoze operating system and Trisquel's.