Evolution + GPG = me going nuts!

6 replies [Last post]
lep
lep
Offline
Joined: 07/31/2014

Hi there!,

I thought I could manage this by myself but I couldn't so that's why I come here looking for help.

I wanted to send an encrypted e-mail, so I grab the recipient's public key copied it into a file and then did:

gpg --import

So the key got imported, because when I do:

gpg --list-keys

It appears on the terminal. Then, I go to evolution and write the email and select the "PGP encrypted" option and when I press "send" it doesn't encrypt the email because of:

Could not create message.

Because "gpg: using subkey XXXXXXXX instead of primary key XXXXXXXX
gpg: No trust check due to `--trust-model always' option
gpg: name at domain: skipped: public key not found
gpg: [stdin]: encryption failed: public key not found
", you may need to select different mail options.

I have tried signing the public key, and restarting evolution several times and finally I gave up...

HELP!! WHAT I'M MISSING HERE?

How can I correctly import a public key if that's the case?

Jodiendo
Offline
Joined: 01/09/2013

read the manual!

lep
lep
Offline
Joined: 07/31/2014

Thanks,

I already did that and didn't find a way out of the problem.

I signed with my key, and I added trust to it. Don't know what's the problem

Jodiendo
Offline
Joined: 01/09/2013

Again read the manual! to encrypt is not easy, neither to cypher, read the manual!
and practice by sending your self a test encrypted e-mail to your other e-mail account that you probably own.
and cypher your encryption. I use gnu/PGP for trisquel, it comes in the repositories.
Are you using trisquel 7 or 6,?

my keys do work

-----BEGIN PGP MESSAGE-----
Version: GnuPG v2

hQEMA7v3OTC0rPDaAQgA2ndcWpravQ7tlsFXhH6NWwl//7Z0cPXe29Ltx+4C//AW
llqBUrMVuLUZNDkcALQ9NgZzFGiI7D+X5Ex0Pz399++QT3/nLDKEjMZc67qp5e2x
36b+01tbACDI0y8O/qBXomxo3qa/NruY5Vpminew/itE7bR2BrFvTcSUAOaxjuTf
1VYqjFtvDR0oovWkMCqH/ZzTUsZsBZSyn7gXNzVQspgP6A7vN6LbU6h7CGccugu6
CvBpHxI5ssAPjrDNCvzmA6rtBD6rpJ13F+tlNmzZSoroQIRwvn21mysIJJFoWYuf
JQU36rHf3NxfWZTsEaCpnwtPzvK6zmBwTm/oS8OeTNI+Abskla/N7LB83OXq0v0F
Dp+ZDAgdHT4HBZ0CCrAMGTOBpDe7sqdxoau3DDE4uZk5gUkKg++75cGgzlkHmwg=
=7Fyv
-----END PGP MESSAGE-----

leny2010

I am a member!

I am a translator!

Offline
Joined: 09/15/2011

It might be that you need to configure Evolution for your own key.

Edit -> Preferences -> Mail Accounts
Click on the mail account then press the Edit Button.
Click on ''Security'
Add your GPG key ID to the panel.

lep
lep
Offline
Joined: 07/31/2014

I think I finally fixed it. Thank you very much guys

pascal@diogoantunes.org
Offline
Joined: 09/03/2012

Em 09.03.2015 12:17, name at domain escreveu:
> I think I finally fixed it. Thank you very much guys