Testing The Trisquel 8 Upgrade Process

53 replies [Last post]
jxself
Offline
Joined: 09/13/2010

It's community involvement time!

One of the things that came from the development meeting on December 8 is the need to test the upgrade process. This is something that anyone can do and report problems in the bug tracker.

It can even be done inside a virtual machine so that you don't have to mess with your existing system.

#1: Install QEMU; sudo apt install qemu

#2: Make an empty disk image: qemu-img create -f qcow2 trisquel-master.qcow2 22G
You can, of course, set whatever size to whatever you want. The qcow2 format only uses as much space as what is actually occupied inside the disk, which will be nothing at first.

#3: Install Trisquel into the master disk image:
qemu-system-x86_64 -hda trisquel-master.qcow2 -cdrom trisquel_7.0_amd64.iso -boot d -enable-kvm
Note that you may need to adjust the qemu system name to qemu-system-i386 if you want to install the 32-bit version of Trisquel, and you will probably also need to adjust the name of the ISO.

#4: Install Trisquel into the virtual machine.

#5: Copy trisquel-master.qcow2 to trisquel.qcow2. In this way you can leave trisquel-master.qcow2 untouched and use it as a snapshot to go back to (by copying it back to trisquel.qcow2 without having to spend the time reinstalling Trisquel.

#6: Boot the system: qemu-system-x86_64 -hda trisquel.qcow2 -enable-kvm
You may need to adjust that name to qemu-system-i386 if you are running the 32-bit version.

Anyway, the next step would be to try upgrading to Trisquel 8. It is important to try over and over and over again with lots of different package combinations to look for breakage, not just upgrading from the defaults because not everyone uses the defaults. Try installing from the netinstall and installing packages and then upgrading.

Regardless, identify cases where things break the upgrade process and report those as bugs on the tracker.

The more testing that is done in advance, the better the upgrade process can be. Find & fix the problems in advance.

Time4Tea
Offline
Joined: 07/16/2017

I don't know if you saw it, but I made a bloggy post a couple of days ago about upgrading from Trisquel 7 to 8 on my Macbook laptop:

Upgrading to Trisquel 8

I ran into problems with some packages breaking, but was able to get the upgrade to work in the end.

jxself
Offline
Joined: 09/13/2010

Please report upgrade problems in the tracker so that they can be addressed and make things easy for everyone.

Time4Tea
Offline
Joined: 07/16/2017

Ok, will do. Where can I find the bug-tracker?

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017
Time4Tea
Offline
Joined: 07/16/2017

Ok, thanks :)

eric23
Offline
Joined: 06/30/2017

Running the "check disc for defects" option gives me a kernel panic.

Screenshot from 2017-12-10 17:52:43.png
ADFENO
Offline
Joined: 12/31/2012

I guess we should report the issue in the tracker?

See the "Issues" link (generally in the right panel).

2017-12-11T01:45:14+0100 name at domain wrote:
> Running the "check disc for defects" option gives me a kernel panic.
>

--
- https://libreplanet.org/wiki/User:Adfeno
- Palestrante e consultor sobre /software/ livre (não confundir com
gratis).
- "WhatsApp"? Ele não é livre. Por favor, veja formas de se comunicar
instantaneamente comigo no endereço abaixo.
- Contato: https://libreplanet.org/wiki/User:Adfeno#vCard
- Arquivos comuns aceitos (apenas sem DRM): Corel Draw, Microsoft
Office, MP3, MP4, WMA, WMV.
- Arquivos comuns aceitos e enviados: CSV, GNU Dia, GNU Emacs Org, GNU
GIMP, Inkscape SVG, JPG, LibreOffice (padrão ODF), OGG, OPUS, PDF
(apenas sem DRM), PNG, TXT, WEBM.

amrprznu
Offline
Joined: 08/12/2013

I didn't have a problem. Did you check your -m (memory) parameter? (running Triquel 7.0 mini here).

calher

I am a member!

Offline
Joined: 06/19/2015

cal@leela:~$ qemu-img create -f qcow2 trisquel-master.qcow2 4G
Formatting 'trisquel-master.qcow2', fmt=qcow2 size=4294967296
encryption=off cluster_size=65536 lazy_refcounts=off
cal@leela:~$ qemu-system-x86_64 -hda trisquel-master.qcow2
-cdrom /media/cal/ISO/boot/ -boot d -enable-kvm
grub/ iso/
cal@leela:~$ qemu-system-x86_64 -hda trisquel-master.qcow2
-cdrom /media/cal/ISO/boot/iso/trisquel_7.0_amd64.iso -boot d
-enable-kvm
Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
cal@leela:~$

jxself
Offline
Joined: 09/13/2010

"No such file or directory"

Well there's your problem. :) Either your CPU doesn't support virtualization, or it's disabled in the BIOS, or KVM is not installed on your computer.

calher

I am a member!

Offline
Joined: 06/19/2015

I'm on a Libreboot X200, where hardware virtualization modules have to
be disabled to stop kernel panics.

jxself
Offline
Joined: 09/13/2010

OK so leave off the KVM stuff then.

vltr
Offline
Joined: 09/30/2017

I tried to do this during the weekend.

I do not know if I did well, but I changed the word "belenos" to flidas in the repositories at /etc/apt/sources.list and later I tried:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

In the second step ("upgrade") the bottom of power dissapeared. After doing "dist-upgraded" it appeared again but I was not able to shut-down the computer neither to restart. The desktop environment looked the same, and I did encounter other errors but now I am not able to recall them here.

For the case of being of some help I will comment here that today I tried to take from the flidas repositories the package for firejail. But I get an error of authetication due to a non recognised key. I leave here my error:

W: GPG error: https://mirror.fsf.org flidas InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B138CA450C05112F

vltr
Offline
Joined: 09/30/2017

Yesterday I tried again to upgrade to Trisquel 8, but I am still having the same problem as when I tried to download just Firejail from those repositories.

I have tried to add the key of the Jenkins repositories as Magic Banana kindly suggested me but the situation is the same, it did not get solved before and neither now when trying to upgrade to Trisquel 8.

Nonetheless, the situation seems to have improved since last time I tried to upgrade to Trisquel 8 (last weekend). On that occasion I was not able to turn off the computer.

This is what I get now in the terminal when I do sudo apt-get update:

sudo apt-get update
[sudo] password for studerende:
0% [Working]
Hit https://linux-libre.fsfla.org freesh InRelease
Hit https://linux-libre.fsfla.org freesh/main amd64 Packages
Hit https://linux-libre.fsfla.org freesh/main i386 Packages
Ign https://mirror.fsf.org flidas InRelease
Ign https://mirror.fsf.org flidas-security InRelease
Ign https://mirror.fsf.org flidas-updates InRelease
Ign https://mirror.fsf.org flidas/main Sources/DiffIndex
Ign https://mirror.fsf.org flidas/main amd64 Packages/DiffIndex
Ign https://mirror.fsf.org flidas/main i386 Packages/DiffIndex
Ign https://linux-libre.fsfla.org freesh/main Translation-en_US
Ign https://linux-libre.fsfla.org freesh/main Translation-en
Ign https://mirror.fsf.org flidas-security/main Sources/DiffIndex
Ign https://mirror.fsf.org flidas-security/main amd64 Packages/DiffIndex
Ign https://mirror.fsf.org flidas-security/main i386 Packages/DiffIndex
Ign https://mirror.fsf.org flidas-updates/main Sources/DiffIndex
Ign https://mirror.fsf.org flidas-updates/main amd64 Packages/DiffIndex
Ign https://mirror.fsf.org flidas-updates/main i386 Packages/DiffIndex
Hit https://mirror.fsf.org flidas/main Sources
Hit https://mirror.fsf.org flidas/main amd64 Packages
Hit https://mirror.fsf.org flidas/main i386 Packages
Hit https://mirror.fsf.org flidas/main Translation-en
Ign https://mirror.fsf.org flidas/main Translation-en_US
Ign https://mirror.fsf.org flidas-security/main Translation-en_US
Ign https://mirror.fsf.org flidas-security/main Translation-en
Ign https://mirror.fsf.org flidas-updates/main Translation-en_US
Ign https://mirror.fsf.org flidas-updates/main Translation-en
Fetched 4,171 kB in 26s (158 kB/s)
Reading package lists... Done
W: GPG error: https://mirror.fsf.org flidas InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B138CA450C05112F
W: GPG error: https://mirror.fsf.org flidas-security InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B138CA450C05112F
W: GPG error: https://mirror.fsf.org flidas-updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B138CA450C05112F
W: Unknown Multi-Arch type 'no' for package 'kwin'
W: Unknown Multi-Arch type 'no' for package 'kwin-dev'
W: Unknown Multi-Arch type 'no' for package 'kwin-wayland'
W: Unknown Multi-Arch type 'no' for package 'kwin-x11'
W: Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'
W: Unknown Multi-Arch type 'no' for package 'libxapian-dev'
W: Ignoring Provides line with DepCompareOp for package php-psr-http-message-implementation
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Unknown Multi-Arch type 'no' for package 'kwin-dev'
W: Unknown Multi-Arch type 'no' for package 'kwin-wayland'
W: Unknown Multi-Arch type 'no' for package 'kwin-x11'
W: Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'
W: Unknown Multi-Arch type 'no' for package 'libxapian-dev'
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package xserver-xorg
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package xserver-xorg

Maybe for my laptop is just too old for having Trisquel 8 running inside it?

I hope hope with this I am helping somehow to the development of Trisquel 8.

Best regards to all.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

About the GPG, it does not look like APT knows about it. Executing the following command in a terminal will import it:
$ apt-key adv --fetch-keys http://jenkins.trisquel.info/archive/trisquel/trisquel-archive-signkey.gpg

That said, you only show warnings. Contrary to errors, warning do not stop the execution.

vltr
Offline
Joined: 09/30/2017

Thank you, Magic Banana.

I tried what you said, but still no success. Here is the report:

:~$ apt-key adv --fetch-keys http://jenkins.trisquel.info/archive/trisquel/trisquel-archive-signkey.gpg
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.vRv7Pc62Yx --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyring /etc/apt/trusted.gpg.d/ubuntukylin-archive-keyring.gpg --fetch-keys http://jenkins.trisquel.info/archive/trisquel/trisquel-archive-signkey.gpg
gpg: key 8D8AEBF1: "Trisquel GNU/Linux (Trisquel GNU/Linux signing key) <name at domain>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1

I also tried with another web, but I am not either able to go ahead:

:~$ apt-key adv --fetch-keys https://mirror.fsf.org/trisquel/trisquel-archive-signkey.gpg
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.ExYSEHxD9E --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyring /etc/apt/trusted.gpg.d/ubuntukylin-archive-keyring.gpg --fetch-keys https://mirror.fsf.org/trisquel/trisquel-archive-signkey.gpg
gpgkeys: protocol `https' not supported
gpg: no handler for keyserver scheme `https'
gpg: WARNING: unable to fetch URI https://mirror.fsf.org/trisquel/trisquel-archive-signkey.gpg: keyserver error

I have also tried to add the key manually in Systems Settings > Passwords and Keys but also nothing happens. When I try later to update the system, I get the same warnings as I reported in the previous post. Sorry for speaking previously about errors instead of warnings. I am still not familiar with the correct way of speaking about so many technical aspects... I thank you all for helping me to learn little by little ; )

gnutastyc
Offline
Joined: 11/13/2017

I have been able to fix it downloading the key manually and then adding it in Systems Settings > Software and Updates > Authentication > Import key. Select your key and it was solved for me.

vltr
Offline
Joined: 09/30/2017

Thank you Gnutastyc. I am going to try that. I hope this is finally the solution.

Thanks again : )

vltr
Offline
Joined: 09/30/2017

Ey Gnutastyc, I think what you said was part of the solution... Well I have not yet tried to upgrade because I came here to explain my progresses, but now there is no warning about the keys recognition so I guess I will not have problem doing that.

I explain what I have done for the warning of the keys to disappear:

I went to "Systems Settings > Software and Updates > Authentication > Import key" as you recommended me, but as I have previously figured out in the "Authentication" label there were already three keys, being one of them the one didn't recognized by the terminal. Anyway, just in case I tried to add the key file again as you recommended me. Nothing seemed to have changed. The three keys continued there.

The three keys that appear are:

8D8AEBF1 Trisquel GNU/Linux singing key
545A3198 Jason Self
0C05112F GNU/Linux

As long as I did not notice anything new, I continued investigating inside the "Software and Updates" window and I noticed that in "Trisquel Software" label the "Officially supported" box was not marked out , so I just thought maybe this box need to be marked and so I did.

After that I went to the terminal and tried "sudo apt-get update". The terminal began to read two or three lines from the belenos repositories (which I do not have now in my repositories list /apt/sources.list) and later proceeded doing the same that it was exposed in my previous posts, showing the same warnings but this time without the warning of the keys.

I tried then to install Firejail and it got installed (before it was not possible), so now I am not stuck there, now my command line is able again to do stuff : )

But now another problem arose: in the lower corner of the window a stop sign appeared and when I click on it it says: "An error occurred please run Package Manager from the right-click menu or apt-get in a terminal to see what is going wrong. The error message was: 'Error Marking the upgrade (...) This usually means that your installed packages have unmet dependencies" and under this dialogue appear several option : Show updates, Install updates , Check for updates and Start Package Manager.

I am going to try to attach a photo here for you all to see.

Any suggestion about what I should do now? I guess I need to remove the tick the previously marked "officially supported (main)" box and to proceed again to try to upgrade to Flidas.

gnutastyc
Offline
Joined: 11/13/2017

As far as I have understood, and tested, and without me being a huge expert this would be a more extensive explanation of the procedure.

1.- Install Trisquel Belenos.
2.- Install all the updates so you end up with the most up-to-date Belenos system.
3.- Install some programs of your choice so their behavior can be checked during upgrade.
4a.- Then, ideally, if you do "sudo apt-get dist-upgrade", the system should guide you to flidas. However, that never happened to me. Probably this option will work once Belenos is out of beta version.
4b.- I thought that the update to flidas is not ready yet, so I modified the files sources.list as you suggested in a previous post. After that, you should import the key as explained before if you want to avoid the gpg warnings.
5b.- sudo apt-get update: If will check the flidas repositories for updates if you have modified the sources.list file. I also receive the same warnings you do, they just should be reported.
6b.- sudo apt-get upgrade: The system will update lots of packages from belenos to flidas.
7b.- sudo apt-get dist-upgrade: The system will install all the remaining updates from belenos to flidas, so at the end, you will have a rolling flidas system instead of belenos. Here we have to check for broken dependencies and errors, so probably it would be great to redirect stderr to a file: sudo apt-get dist-upgrade 2> dist-upgrade.err.log

If someone with more knowledge can point if something of what I've said is wrong, it would be awesome. As far as I have figured out, this is the way to proceed, hope it helps you :)

pikurasa
Offline
Joined: 02/15/2018

> apt-key adv --fetch-keys http://jenkins.trisquel.info/archive/trisquel/trisquel-archive-signkey.gpg

This did not work for me as is, however it was helpful.

I had to first download the key with

`wget http://jenkins.trisquel.info/archive/trisquel/trisquel-archive-signkey.gpg`

...and then...

`apt-key add trisquel-archive-signkey.gpg`

Then I was able to authenticate for upgrade. I hope this helps someone else.

mixalis_t
Offline
Joined: 02/21/2014

Is it possible to upgrade to flidas from belenos using the update manager?

Time4Tea
Offline
Joined: 07/16/2017

Yes - I have done so on my Macbook. I made a post providing some of the details of it here. It wasn't completely smooth, but you might find it goes more smoothly now some more package have been fixed. Good luck! :-)

EDIT: Oh, the Update Manager. Sorry, I did it using apt-get dist-upgrade. I haven't tried it with the Update Manager yet.

Time4Tea
Offline
Joined: 07/16/2017

I was probably expecting too much for this virtualization approach to work on my laptop (Core 2 Duo Macbook 2,1 with only 1GB of RAM). I tried the 'Try Trisquel Without Installing' option from the ISO and it did try to boot up in Qemu, but it was unusably slow.

Is it possible to boot up directly into Qemu with GRUB, or boot from the disk image, thus avoiding having to load the 'native' system on my laptop first? :-(

amrprznu
Offline
Joined: 08/12/2013

I hope that this helps: https://3g2upl4pq6kufc4m.onion/?q=grub+boot+iso (it will if you are using Tor with your browser)

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

I tried to upgrade my older laptop (which is taking dust) from Trisquel 7 to Trisquel 8. I first disabled the external repositories (e.g., jxself's since I use the latest Linux-libre). After discovering that neither 'update-manager -d' nor 'sudo do-release-upgrade -d' would propose me to update, I replaced all "belenos" in /etc/apt/sources.list with "flidas" ('sudo sed -i s/belenos/flidas/' /etc/apt/sources.list) and:

  1. I ran 'sudo apt upgrade'. At that point I thought everything went well and just copied the errors/warnings into "1. original-apt-upgrade.txt". However, I was about to discover that the last logged error is malignant:
    Errors were encountered while processing:
    libclutter-imcontext-0.1-bin
    ibus-clutter:amd64
    sa-compile
    E: Sub-process /usr/bin/dpkg returned an error code (1)
  2. A reboot later, GDM did not start. I logged into tty1 and tried again 'sudo apt upgrade'. In vain. The log, "2. failed-apt-upgrade-after-reboot.txt", ends with:
    /usr/bin/clutter-scan-immodules: relocation error: /usr/lib/x86_64-linux-gnu/libboost_system.so.1.58.0: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEED1Ev, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
    dpkg: error processing package libclutter-imcontext-0.1-bin (--configure):
    subprocess installed post-installation script returned error exit status 127
    dpkg: dependency problems prevent configuration of ibus-clutter:amd64:
    ibus-clutter:amd64 depends on libclutter-imcontext-0.1-bin; however:
    Package libclutter-imcontext-0.1-bin is not configured yet.
    dpkg: error processing package ibus-clutter:amd64 (--configure):
    dependency problems - leaving unconfigured
    Setting up sa-compile (3.4.1-3) ...
    Running sa-compile (may take a long time)
    re2c: relocation error: re2c: symbol _ZTTNSt7__cxx1119basic_ostringstreamIcSt11char_traitsIcESaIcEEE, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
    /usr/bin/sa-compile requires re2c for proper operation.
    dpkg: error processing package sa-compile (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    libclutter-imcontext-0.1-bin
    ibus-clutter:amd64
    sa-compile
    E: Sub-process /usr/bin/dpkg returned an error code (1)
  3. Since before that, there was a long list of packages to "autoremove", I did 'sudo apt-get autoremove' and, again, 'sudo apt upgrade', which upgraded 43 packages and installed 131 packages. However, the log, "3. apt-upgrade-after-autoremove.txt", ended like before:
    Errors were encountered while processing:
    libclutter-imcontext-0.1-bin
    ibus-clutter:amd64
    sa-compile
    E: Sub-process /usr/bin/dpkg returned an error code (1)
  4. I therefore decided to 'sudo apt remove sa-compile', what went well, according to "4. apt-remove-sa-compile.txt".
  5. I proceeded to 'sudo apt remove libclutter-imcontext-0.1-bin', that went well too, according to "5. apt-remove-libclutter-imcontext-0.1-bin.txt" (and "ibus-clutter" depending on "libclutter-imcontext-0.1-bin", it was removed as well).
  6. After all that, I still could not get a graphical session. Probably because 'sudo apt-get autoremove' removed too much, I thought. I therefore decided to install the default desktop with 'sudo apt install trisquel', which apparently went well (I did not save the logs). On the contrary, 'sudo apt install trisquel-recommended' does not work, for depending on packages that are still absent (if I remember well the error).
  7. I executed 'sudo start lightdm' and could log into the MATE desktop... but the icons on the desktop did not load, the cursor spun forever and the system was lagging a lot. I managed after some time to get back to tty1 and 'top' showed me that 'mate-settings-daemon' (if I remember well) and X were occupying the CPU.
  8. Worse, any attempt to use 'apt' or 'apt-get' (even to just show its version with "-v") now gives this error:
    apt: relocation error: /usr/lib/x86_64-linux-gnu/libapt-pkg.so.5.0: symbol _ZNKSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE7compareERKS4_, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
  9. I hope that helps to fix issues in the upgrade process. It does not look ready. At least not for my selection of packages. I did not think of saving that selection (which notably includes GNOME Shell) before the upgrade. However, my current laptop has a similar selection. Indeed, I used https://trisquel.info/en/wiki/cloning-system-or-how-make-copy-installed-packages-one-computer-another to initially set it up a few months ago. I can give its list of installed packages, if useful.

    I will try to install from ISO on the older laptop.

AttachmentSize
1. original-apt-upgrade.txt 3.99 KB
2. failed-apt-upgrade-after-reboot.txt 14.61 KB
3. apt-upgrade-after-autoremove.txt 71.81 KB
4. apt-remove-sa-compile.txt 2.85 KB
5. apt-remove-libclutter-imcontext-0.1-bin.txt 2.99 KB
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

The dysfunctional APT (and the other problems?) is apparently a consequence of me using ppa:ubuntu-toolchain-r/test: https://askubuntu.com/questions/777803/apt-relocation-error-version-glibcxx-3-4-21-not-defined-in-file-libstdc-so-6

I had that PPA (and all other external repository) disabled before the upgrade but I believe I should have removed all the packages coming from it.

This morning I discovered that the versions 4.9.39-gnu, 4.9.40-gnu, 4.14.10-gnu (all from jxself's Linux-libre repository), 4.4.0-104 (Trisquel 8's default) or 3.13.0-137 (Trisquel 7's default) of the kernel would all "panic" when they boot, even in "recovery mode". So, yes, it does not look I have options (such as those suggested in the page I linked above) but installing from an ISO.

A warning for those using the "Ubuntu toolchain PPA" would be good in Trisquel 8's release notes, I guess.

pikurasa
Offline
Joined: 02/15/2018

> A warning for those using the "Ubuntu toolchain PPA" would be good in Trisquel 8's release notes, I guess.

I ran into similar issues as you describe for different PPA's

I think a warning for any PPA's should be given.

As for me, I read the risks beforehand, but I was too lazy to head the warnings. I removed the PPA's, but I should have purged them instead as recommended.

Thanks for all the detail Magic Banana. I am still troubleshooting some of my issues with the install (which was temporarily successful, but now quite the perplexing rabbit hole)

oshanz
Offline
Joined: 02/12/2012

Damn, I'm screwed. so nothing to do right now? except for format and install. :-(

later:

manually download and installed libstdc saved me, phew :-)

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

The amd64 ISO of December 24th works great. I am currently typing from the live system.

I "burned" it on a USB pendrive (the FSF member card actually) using Trisquel 7's graphical "USB Creator" (or whatever it is called). Although it looks stuck at some point (at 42% and at 99%, when creating the permanent file), it all ended well.

It was written here that the ath9k_htc firmware was missing from the older ISOs. It was certainly true (I did not try these ISOs). With that latest ISO, my Wifi works out of the box. So do KabyLake graphics apparently. I was having screen scrambling with some graphical applications on Trisquel 7.

Some weird things in the ISO:

  • Why is the ugly "Galculator" present since the "Calculator" is present as well?
  • What is "Icedove -> Thunderbird" in the "Other" category?
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

I installed the ISO on my older laptop. No problem. I installed GNOME Shell. No problem either. However, the "cross" to close some windows is extra-large, going out of its "box". It works though.

Now the weirdest thing, which may be a freedom issue: my internal Wifi card works! I do not need the USB adapter with the AR9271 chipset! As far as I know there is no free firmware for the chipset in my internal card:
$ lspci | grep Network
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

According to h-node and the Debian wiki pages that chipset requires non-free realtek firmware. Congrats, you just found a bug!

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Although the installation of GNOME Shell presents no problem, it is useless alone: most of the MATE applications (in particular setting tools) are indeed inaccessible, but from a command prompt or a terminal emulator. That includes the file manager and only installing "gnome-shell" does not put icons on the desktop! 'mate-menu' would not even start from the terminal. Anyway, I do not think it would change what GNOME Shell proposes in its dash.

The solution I adopted was to install the "gnome" package. It is simple but not smart (I will search for a better way): I ended up with pairs of similar applications serving the same purpose: MATE Terminal and GNOME Terminal, Pidgin and Empathy, RhythmBox and GNOME Music, Atril and Evince, Pluma and GEdit, Thunderbird and Evolution, etc. APT asking, I choose GDM3 as the default display manager. Although I do not know if it is the cause, the graphical session then crashed. I logged into tty1, executed 'sudo systemctl start gdm3.service' and could log back into the GNOME session. There now were icons on the desktop. Weirdly enough, the installation of "gnome" and its dependencies apparently continued despite the crash of the graphical session.

The default theme has problems. I already mentioned the too-large crosses to close some windows. However, the problems look more general than that. See attached a screenshot of the Nautilus window: small and large icons listed together in the left pane; small and large button at the top; the cross is OK here. I believe that theme problem affects the default MATE desktop too. For instance, the launchers, at the left of the panel, look too closely packed.

I do not know whether 'trisquel-compton-switcher' and 'trisquel-wm-chooser' are still useful. The former script does not execute because of a supernumerary character, ^M, at the end of the shebang line. The latter script looks redundant with the last setting "MATE Tweak" proposes to setup... and that apparently always turn the graphical session unusable!

I question as well the usefulness of having "Vim", XTerm/UXTerm", "ImageMagick (display)" in the menu or even installed at all, user-friendly alternatives being installed as well.

Finally I was happy to not see any GRUB password in Trisquel 8! I hope it will stay that way.

Nautilus.png
gnutastyc
Offline
Joined: 11/13/2017

Both Calculators might be available so more things can be tested in the images without having to install them.

That thing in the Other category is another link to Thunderbird email client... Which is weird, as there is also one in the Internet category. I guess it's just a mistake.

jules_verne
Offline
Joined: 01/02/2017

I did everything listed and got only one problem.
Since the upgrade to Trisquel 8 I could not install any package or execute update.
Terminal kept responding with:

Erros foram encontrados durante o processamento de:
plymouth-theme-trisquel-logo
E: Sub-process /usr/bin/dpkg returned an error code (1)

It was fixed by removing plymouth:

sudo apt-get remove plymouth-theme-trisquel-logo

Ps: I live in Brazil and my laptop is currently at portuguese. But I don't believe that any of you will find it hard to understand the error. Anyway: Errors were encountered during the processing of: plymouth-theme-trisquel-logo.

Ps²: The only difference is the lack of image once I start the computer, which is not a problem at all, at least for me.

Edit1: by image I mean the art displayed just before the login.

Time4Tea
Offline
Joined: 07/16/2017

I had problems with that package when I upgraded from Trisquel 7 to 8 as well.

gnutastyc
Offline
Joined: 11/13/2017

It is already fixed in the beta version, but it has not been rebuilt in the repos, I guess. However, It's awesome that you didn't have any other errors.

Time4Tea
Offline
Joined: 07/16/2017

I'm happy to do some more testing on this, if further testing of the upgrade process is needed. However, I have a question:

What is the best way to log the output of apt-get? I would think the logs of 'apt-get upgrade' and 'apt-get dist-upgrade' would be invaluable when it comes to tracking down the bugs. Should we use 'tee' to copy the output to a file, or does apt-get keep log files somewhere, which we can just copy-paste?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

'tee' is a good solution. Also:

  • Precede the command with "LC_ALL=C" to have the command use the system locale (English); a tip for jules_verne too;
  • Use 'apt-get' and not 'apt' (like I did) because its colored output messes the log a little.

For example, that command generates good logs (here, in a file named "log"):
LC_ALL=C sudo apt-get upgrade | tee log

/var/log/apt/term.log.* contains APT's logs too.

tomlukeywood
Offline
Joined: 12/05/2014

I have tried to boot the amd64 Trisquel 8 iso from here: http://jenkins.trisquel.info/makeiso/iso/

in qemu-system-x86_64 and i received the attached panic screen

kernel_panic_trisquel8.png
tomlukeywood
Offline
Joined: 12/05/2014

oh wait the problem was i had not specified the RAM and it defaulted to 512mb i have changed to 2GB and now it boots fine.

and i was able to upgrade to trisquel 8 fine.

Cyberhawk

I am a translator!

Offline
Joined: 07/27/2010

I've been trying to follow the instructions by jxself to create a VM with Trisquel 7. Wanted to try out the netinstall .iso. This failed however: "the installer failed to download a file from the mirror. This may be a problem with your network, or with the mirror."

It gave me the option to retry or change the mirror. The mirrors in France, US and Spain did not work for me.

The file unavailable for download was: message-modules-3.13.0-37-generic-di.

Is this a temporary issue with the mirrors, or the qemu itself? It appears my netinstall image is fine according to md5sum check. I installed a Trisquel 7 system on real hardware today with a working netinstall CD, so it is not a general bug in the netinstall image.

soy comic
Offline
Joined: 12/17/2016
davidpgil
Offline
Joined: 08/26/2015

When you do the upgrade from Trisquel 7 are you making sure that you don't have any other repositories and/or PPAs available. If you do have them, I recommend removing them and doing the upgrade after they are removed. My issue was with the Trisquel upgrader getting confused with installing the wrong versions of packages.

Here is what I did to solve my issue which my be related to yours:
https://trisquel.info/en/forum/trisquel-8-codename-flidas-release-candidate-ready-testing#comment-130967

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

I have both the packages "texlive-latex-base-doc" and "texlive-latex-recommended-doc" installed on Trisquel 8 but no directory "/etc/texmf/updmap.d/". I would therefore simply remove /etc/texmf/updmap.d/ and see if that solves the problem:
$ sudo rm -r /etc/texmf/updmap.d/

soy comic
Offline
Joined: 12/17/2016

It got rid of the warnings, but the error remains:
dpkg: error processing archive /var/cache/apt/archives/texlive-latex-base-doc_2015.20160320-1ubuntu0.1_all.deb (--unpack):
trying to overwrite '/usr/share/doc/texlive-doc/latex/url/miscdoc.sty', which is also in package texlive-latex-recommended-doc 2013.20140215-1ubuntu0.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/texlive-latex-base-doc_2015.20160320-1ubuntu0.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

2013.20140215-1ubuntu0.1 is the Trisquel 7 version of "texlive-latex-recommended-doc". It provides the file /usr/share/doc/texlive-doc/latex/url/miscdoc.sty. Trisquel 8's version is 2015.20160320-1ubuntu0.1 and it does not provide that file. Trisquel 8's "texlive-latex-base-doc" provides it. So, removing "texlive-latex-recommended-doc" (that you can reinstall after) should solve the problem.

soy comic
Offline
Joined: 12/17/2016

Right, but look back at the issue. First thing I tried was to attempt apt-get remove texlive*.

For example:

$ sudo apt-get remove -f feynmf prosper m-tx pgf pmx musixtex tipa texlive* *latex*
Reading package lists...
Building dependency tree...
Reading state information...
Package 'texlive-base-recommended' is not installed, so not removed
Package 'texlive-base-bin-doc' is not installed, so not removed
Package 'texlive-texinfo' is not installed, so not removed
Package 'texlive-common' is not installed, so not removed
Package 'texlive-lang-arab' is not installed, so not removed
Package 'texlive-doc-bg' is not installed, so not removed
Package 'texlive-doc-fi' is not installed, so not removed
Package 'texlive-doc-nl' is not installed, so not removed
Package 'texlive-doc-si' is not installed, so not removed
Package 'texlive-doc-tr' is not installed, so not removed
Package 'texlive-lang-armenian' is not installed, so not removed
Package 'texlive-lang-croatian' is not installed, so not removed
Package 'texlive-lang-danish' is not installed, so not removed
Package 'texlive-lang-dutch' is not installed, so not removed
Package 'texlive-lang-finnish' is not installed, so not removed
Package 'texlive-lang-hungarian' is not installed, so not removed
Package 'texlive-lang-latvian' is not installed, so not removed
Package 'texlive-lang-lithuanian' is not installed, so not removed
Package 'texlive-lang-norwegian' is not installed, so not removed
Package 'texlive-lang-swedish' is not installed, so not removed
Package 'texlive-doc-ar' is not installed, so not removed
Package 'texlive-doc-cs+sk' is not installed, so not removed
Package 'texlive-doc-de' is not installed, so not removed
Package 'texlive-doc-en' is not installed, so not removed
Package 'texlive-doc-es' is not installed, so not removed
Package 'texlive-doc-fr' is not installed, so not removed
Package 'texlive-doc-it' is not installed, so not removed
Package 'texlive-doc-ja' is not installed, so not removed
Package 'texlive-doc-ko' is not installed, so not removed
Package 'texlive-doc-mn' is not installed, so not removed
Package 'texlive-doc-pl' is not installed, so not removed
Package 'texlive-doc-pt' is not installed, so not removed
Package 'texlive-doc-rs' is not installed, so not removed
Package 'texlive-doc-ru' is not installed, so not removed
Package 'texlive-doc-th' is not installed, so not removed
Package 'texlive-doc-uk' is not installed, so not removed
Package 'texlive-doc-vi' is not installed, so not removed
Package 'texlive-doc-zh' is not installed, so not removed
Package 'texlive-lang-hebrew' is not installed, so not removed
Package 'texlive-lang-mongolian' is not installed, so not removed
Package 'texlive-lang-tibetan' is not installed, so not removed
Package 'texlive-lang-vietnamese' is not installed, so not removed
Package 'biblatex' is not installed, so not removed
Package 'cslatex' is not installed, so not removed
Package 'jlatex209-bin' is not installed, so not removed
Package 'latex-cjk' is not installed, so not removed
Package 'latex-cjk-xcjk' is not installed, so not removed
Package 'libjlatexmath' is not installed, so not removed
Package 'platex-base' is not installed, so not removed
Package 'latex-sanskrit' is not installed, so not removed
Package 'thailatex' is not installed, so not removed
Package 'latex.service' is not installed, so not removed
Package 'latex' is not installed, so not removed
Package 'c++-annotations-latex' is not installed, so not removed
Package 'cjk-latex' is not installed, so not removed
Package 'csv2latex' is not installed, so not removed
Package 'cweb-latex' is not installed, so not removed
Package 'dblatex' is not installed, so not removed
Package 'fcitx-table-latex' is not installed, so not removed
Package 'geany-plugin-latex' is not installed, so not removed
Package 'gedit-latex-plugin' is not installed, so not removed
Package 'gnuhtml2latex' is not installed, so not removed
Package 'ibus-table-latex' is not installed, so not removed
Package 'jlatex209-base' is not installed, so not removed
Package 'klatexformula' is not installed, so not removed
Package 'latex-cjk-all' is not installed, so not removed
Package 'latex-cjk-chinese' is not installed, so not removed
Package 'latex-cjk-chinese-arphic-bkai00mp' is not installed, so not removed
Package 'latex-cjk-chinese-arphic-bsmi00lp' is not installed, so not removed
Package 'latex-cjk-chinese-arphic-gbsn00lp' is not installed, so not removed
Package 'latex-cjk-chinese-arphic-gkai00mp' is not installed, so not removed
Package 'latex-cjk-common' is not installed, so not removed
Package 'latex-cjk-japanese' is not installed, so not removed
Package 'latex-cjk-japanese-wadalab' is not installed, so not removed
Package 'latex-cjk-korean' is not installed, so not removed
Package 'latex-cjk-thai' is not installed, so not removed
Package 'latex-coffee-stains' is not installed, so not removed
Package 'latex-fonts-sipa-arundina' is not installed, so not removed
Package 'latex-fonts-thai-tlwg' is not installed, so not removed
Package 'latex-make' is not installed, so not removed
Package 'latex-mk' is not installed, so not removed
Package 'latex209-base' is not installed, so not removed
Package 'latex209-bin' is not installed, so not removed
Package 'latex209-src' is not installed, so not removed
Package 'latex2html' is not installed, so not removed
Package 'latex2rtf' is not installed, so not removed
Package 'latex2rtf-doc' is not installed, so not removed
Package 'latexdiff' is not installed, so not removed
Package 'latexdraw' is not installed, so not removed
Package 'latexila' is not installed, so not removed
Package 'latexila-data' is not installed, so not removed
Package 'latexmk' is not installed, so not removed
Package 'latexml' is not installed, so not removed
Package 'libjlatexmath-fop-java' is not installed, so not removed
Package 'libjlatexmath-java' is not installed, so not removed
Package 'libjlatexmath-java-doc' is not installed, so not removed
Package 'libklatexformula3' is not installed, so not removed
Package 'libklatexformula3-dev' is not installed, so not removed
Package 'liblatex-decode-perl' is not installed, so not removed
Package 'liblatex-driver-perl' is not installed, so not removed
Package 'liblatex-encode-perl' is not installed, so not removed
Package 'liblatex-table-perl' is not installed, so not removed
Package 'liblatex-tom-perl' is not installed, so not removed
Package 'libreoffice-writer2latex' is not installed, so not removed
Package 'libtemplate-plugin-latex-perl' is not installed, so not removed
Package 'libwriter2latex-java' is not installed, so not removed
Package 'libwriter2latex-java-doc' is not installed, so not removed
Package 'linuxdoc-tools-latex' is not installed, so not removed
Package 'mediawiki2latex' is not installed, so not removed
Package 'mediawiki2latexguipyqt' is not installed, so not removed
Package 'pidgin-latex' is not installed, so not removed
Package 'rcs-latex' is not installed, so not removed
Package 'texlive-bibtex-extra' is not installed, so not removed
Package 'texlive-binaries' is not installed, so not removed
Package 'texlive-extra-utils' is not installed, so not removed
Package 'texlive-font-utils' is not installed, so not removed
Package 'texlive-fonts-extra' is not installed, so not removed
Package 'texlive-formats-extra' is not installed, so not removed
Package 'texlive-games' is not installed, so not removed
Package 'texlive-generic-extra' is not installed, so not removed
Package 'texlive-htmlxml' is not installed, so not removed
Package 'texlive-humanities' is not installed, so not removed
Package 'texlive-lang-african' is not installed, so not removed
Package 'texlive-lang-all' is not installed, so not removed
Package 'texlive-lang-arabic' is not installed, so not removed
Package 'texlive-lang-chinese' is not installed, so not removed
Package 'texlive-lang-cjk' is not installed, so not removed
Package 'texlive-lang-cyrillic' is not installed, so not removed
Package 'texlive-lang-czechslovak' is not installed, so not removed
Package 'texlive-lang-english' is not installed, so not removed
Package 'texlive-lang-european' is not installed, so not removed
Package 'texlive-lang-french' is not installed, so not removed
Package 'texlive-lang-german' is not installed, so not removed
Package 'texlive-lang-greek' is not installed, so not removed
Package 'texlive-lang-indic' is not installed, so not removed
Package 'texlive-lang-italian' is not installed, so not removed
Package 'texlive-lang-japanese' is not installed, so not removed
Package 'texlive-lang-korean' is not installed, so not removed
Package 'texlive-lang-other' is not installed, so not removed
Package 'texlive-lang-polish' is not installed, so not removed
Package 'texlive-lang-portuguese' is not installed, so not removed
Package 'texlive-lang-spanish' is not installed, so not removed
Package 'texlive-math-extra' is not installed, so not removed
Package 'tomboy-latex' is not installed, so not removed
Package 'vim-latexsuite' is not installed, so not removed
Package 'writer2latex' is not installed, so not removed
Package 'writer2latex-manual' is not installed, so not removed
Package 'doxygen-latex' is not installed, so not removed
Package 'texlive' is not installed, so not removed
Package 'texlive-fonts-recommended' is not installed, so not removed
Package 'texlive-full' is not installed, so not removed
Package 'texlive-generic-recommended' is not installed, so not removed
Package 'texlive-latex-base' is not installed, so not removed
Package 'texlive-doc-base' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
trisquel-desktop-common : Depends: fonts-droid-fallback but it is not going to be installed
Depends: irqbalance but it is not going to be installed
Depends: fonts-roboto but it is not going to be installed
Recommends: ibus-clutter but it is not going to be installed
Recommends: ibus-doc but it is not going to be installed
Recommends: ibus-qt4 but it is not going to be installed
Recommends: ibus-table-array30 but it is not going to be installed
Recommends: ibus-table-cangjie but it is not going to be installed
Recommends: ibus-table-cangjie-big but it is not going to be installed
Recommends: ibus-table-cangjie3 but it is not going to be installed
Recommends: ibus-table-cangjie5 but it is not going to be installed
Recommends: ibus-table-cantonese but it is not going to be installed
Recommends: ibus-table-cantonhk but it is not going to be installed
Recommends: ibus-table-cns11643 but it is not going to be installed
Recommends: ibus-table-compose but it is not going to be installed
Recommends: ibus-table-easy but it is not going to be installed
Recommends: ibus-table-easy-big but it is not going to be installed
Recommends: ibus-table-emoji but it is not going to be installed
Recommends: ibus-table-erbi but it is not going to be installed
Recommends: ibus-table-erbi-qs but it is not going to be installed
Recommends: ibus-table-ipa-x-sampa but it is not going to be installed
Recommends: ibus-table-jyutping but it is not going to be installed
Recommends: ibus-table-latex but it is not going to be installed
Recommends: ibus-table-quick but it is not going to be installed
Recommends: ibus-table-quick-classic but it is not going to be installed
Recommends: ibus-table-quick3 but it is not going to be installed
Recommends: ibus-table-quick5 but it is not going to be installed
Recommends: ibus-table-rustrad but it is not going to be installed
Recommends: ibus-table-scj6 but it is not going to be installed
Recommends: ibus-table-stroke5 but it is not going to be installed
Recommends: ibus-table-thai but it is not going to be installed
Recommends: ibus-table-translit but it is not going to be installed
Recommends: ibus-table-translit-ua but it is not going to be installed
Recommends: ibus-table-viqr but it is not going to be installed
Recommends: ibus-table-wu but it is not going to be installed
Recommends: ibus-table-wubi but it is not going to be installed
Recommends: ibus-table-yawerty but it is not going to be installed
Recommends: ibus-table-yong but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

What happens if you follow the advice at the end of the output?
$ sudo apt-get -f install

soy comic
Offline
Joined: 12/17/2016

$ sudo apt-get -f install
Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
appmenu-qt appmenu-qt5 automake1.4 fonts-cabin fonts-comfortaa
fonts-font-awesome fonts-freefont-otf fonts-gfs-artemisia
fonts-gfs-baskerville fonts-gfs-complutum fonts-gfs-didot
fonts-gfs-neohellenic fonts-gfs-olga fonts-gfs-porson fonts-gfs-solomos
fonts-inconsolata fonts-lato fonts-linuxlibertine fonts-lobster
fonts-lobstertwo fonts-oflb-asana-math gir1.2-gconf-2.0
gstreamer0.10-fluendo-mp3 gstreamer0.10-gnonlin gstreamer0.10-nice
gstreamer0.10-plugins-base:i386 gstreamer1.0-clutter gtk2-engines:i386
gtk2-engines-murrine:i386 gtk2-engines-oxygen:i386 gtk2-engines-pixbuf:i386
gvfs:i386 gvfs-libs:i386 ibus-gtk:i386 indicator-appmenu latex-beamer
latex-xcolor libaa1:i386 libaio1:i386 libao4:i386 libapt-inst1.5
libarchive-extract-perl libasn1-8-heimdal:i386 libasound2:i386
libasound2-plugins:i386 libasyncns0:i386 libatk1.0-0:i386 libaudio2:i386
libaudiofile1:i386 libavahi-client3:i386 libavahi-common-data:i386
libavahi-common3:i386 libavc1394-0:i386 libbasicusageenvironment0 libblas3gf
libcaca0:i386 libcairo-gobject2:i386 libcairo2:i386 libcamel-1.2-45
libcanberra-gtk-module:i386 libcanberra-gtk0:i386 libcanberra0:i386
libcapi20-3:i386 libcdparanoia0:i386 libcgmanager0:i386 libclass-load-perl
libcmis-0.4-4 libcommon-sense-perl libcroco3:i386 libcrypt-passwdmd5-perl
libcups2:i386 libcupsfilters1:i386 libcupsimage2:i386 libcurl3:i386
libdata-optlist-perl libdatrie1:i386 libdbus-1-3:i386 libdbus-glib-1-2:i386
libdbusmenu-qt2 libdv4:i386 libdvbpsi8 libebackend-1.2-7 libebook-1.2-14
libebook-contacts-1.2-0 libedata-book-1.2-20 libedataserver-1.2-18
libegl1-mesa-drivers libelfg0 libesd0:i386 libexif12:i386 libexpat1:i386
libexporter-lite-perl libfarstream-0.1-0 libflac8:i386 libfluidsynth1:i386
libfontconfig1:i386 libfreetype6:i386 libfriends0 libgail-common:i386
libgail18:i386 libgck-1-0:i386 libgconf-2-4:i386 libgcr-base-3-1:i386
libgcrypt11:i386 libgd2-xpm:i386 libgd3:i386 libgdata13 libgdbm3:i386
libgdk-pixbuf2.0-0:i386 libgettextpo0:i386 libglamor0 libglewmx1.10
libglu1-mesa:i386 libgnome-bluetooth11 libgnutls26:i386 libgphoto2-2:i386
libgphoto2-6:i386 libgphoto2-port0:i386 libgphoto2-port10:i386
libgphoto2-port12:i386 libgraphite2-3:i386 libgrip0 libgroupsock1
libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
libgstreamer-plugins-base0.10-0:i386 libgstreamer-plugins-base1.0-0:i386
libgstreamer-vaapi1.0-0 libgstreamer0.10-0:i386 libgstreamer1.0-0:i386
libgtk2.0-0:i386 libgtkhtml-4.0-0 libgtkhtml-4.0-common
libgtkhtml-editor-4.0-0 libgtksourceview2.0-0 libgtksourceview2.0-common
libgtop2-7 libgudev-1.0-0:i386 libharfbuzz0b:i386 libhcrypto4-heimdal:i386
libhdf5-7 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
libhx509-5-heimdal:i386 libibus-1.0-5:i386 libice6:i386 libiec61883-0:i386
libieee1284-3:i386 libimobiledevice4 libio-stringy-perl
libjack-jackd2-0:i386 libjasper1:i386 libjbig0:i386 libjpeg-turbo8:i386
libjpeg8:i386 libjson-c2:i386 libjson-perl libjson-xs-perl libjson0
libjson0:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386
libkrb5-3:i386 libkrb5support0:i386 liblapack3gf libldap-2.4-2:i386
liblivemedia23 libllvm3.4 liblog-message-simple-perl libltdl7:i386
libmad0:i386 libmagick++5 libmikmod2:i386 libminiupnpc8 libmirclient7
libmirclientplatform-mesa libmirprotobuf-dev libmirprotobuf0
libmpg123-0:i386 libnetcdfc7 libnih-dbus1:i386 libnih1:i386 libnotify-bin
libnspr4:i386 libnss3:i386 liboath0 libodbc1:i386 libogg0:i386 liboil0.3
libopenal1:i386 libopenvg1-mesa liborc-0.4-0:i386 libpackage-stash-perl
libpackage-stash-xs-perl libpango-1.0-0:i386 libpango1.0-0:i386
libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 libpangox-1.0-0:i386
libpangoxft-1.0-0:i386 libparams-util-perl libparse-debcontrol-perl
libpcre32-3 libpixman-1-0:i386 libplist1 libpng12-0:i386 libpod-latex-perl
libpoppler19 libprotobuf-lite8 libprotobuf8 libpulse-mainloop-glib0:i386
libpulse0:i386 libpulsedsp:i386 libqpdf13 libqt4-dbus:i386
libqt4-declarative:i386 libqt4-designer:i386 libqt4-network:i386
libqt4-opengl:i386 libqt4-qt3support:i386 libqt4-script:i386
libqt4-scripttools:i386 libqt4-sql:i386 libqt4-svg:i386 libqt4-test:i386
libqt4-xml:i386 libqt4-xmlpatterns:i386 libqt5positioning5 libqt5sensors5
libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
libraw1394-11:i386 librhythmbox-core8 libroken18-heimdal:i386
librsvg2-2:i386 librsvg2-common:i386 librtmp0:i386 libsamplerate0:i386
libsane:i386 libsasl2-2:i386 libsasl2-modules-db:i386 libsdl-image1.2:i386
libsdl-mixer1.2:i386 libsdl-net1.2:i386 libsdl-ttf2.0-0:i386
libsdl1.2debian:i386 libsecret-1-0:i386 libsexy2 libshout3:i386
libslang2:i386 libsm6:i386 libsndfile1:i386 libspeex1:i386 libspeexdsp1:i386
libssl0.9.8:i386 libssl1.0.0:i386 libstdc++5:i386 libsub-install-perl
libsword-common libsystemd-daemon0 libsystemd-journal0 libt1-5 libtar0
libtdb1:i386 libterm-ui-perl libtext-soundex-perl libthai0:i386
libtheora0:i386 libtiff4 libtiff5:i386 libtk8.5 libtypes-serialiser-perl
libunistring0:i386 libunity-gtk2-parser0 libunity-gtk3-parser0
libupower-glib1 libusageenvironment1 libusb-0.1-4:i386 libusb-1.0-0:i386
libusbmuxd2 libv4l-0:i386 libv4lconvert0:i386 libvisual-0.4-0:i386
libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libvpx1:i386
libwavpack1:i386 libwebp5:i386 libwind0-heimdal:i386 libwnck-common
libwnck22 libwpd-0.9-9 libwpg-0.2-2 libwps-0.3-3 libwrap0:i386 libxaw7:i386
libxcb-render0:i386 libxcb-shm0:i386 libxcb-util0 libxcomposite1:i386
libxcursor1:i386 libxft2:i386 libxi6:i386 libxinerama1:i386 libxmu6:i386
libxp6:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386
libxss1:i386 libxt6:i386 libxtst6:i386 libxv1:i386 libyajl1 m-tx
m17n-contrib musixtex odbcinst odbcinst1debian2 odbcinst1debian2:i386
perlmagick pgf phonon-backend-gstreamer1.0 pmx python-dbus-dev
python-gtksourceview2 python-pexpect telepathy-indicator
texlive-fonts-extra-doc texlive-humanities-doc tk8.5 ttf-adf-accanthis
ttf-adf-gillius ttf-dejavu ttf-dejavu-extra unity-gtk-module-common
unity-gtk2-module unity-gtk3-module unity-lens-friends unity-scope-audacious
unity-scope-clementine unity-scope-gmusicbrowser unity-scope-gourmet
unity-scope-guayadeque unity-scope-musique watershed xaw3dg:i386
xchat-common xfonts-mathml xiphos-data
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
fonts-droid-fallback fonts-noto-mono fonts-roboto fonts-roboto-hinted
irqbalance libfile-homedir-perl libfile-which-perl libkpathsea6 libpotrace0
libptexenc1 libsynctex1 libtexlua52 libtexluajit2 libzzip-0-13 tex-common
texlive-base texlive-binaries texlive-extra-utils texlive-font-utils
texlive-fonts-recommended texlive-generic-recommended texlive-lang-european
texlive-latex-base texlive-latex-base-doc texlive-latex-extra
texlive-latex-extra-doc texlive-latex-recommended
texlive-latex-recommended-doc texlive-luatex texlive-metapost
texlive-metapost-doc texlive-music texlive-omega texlive-pictures
texlive-pictures-doc texlive-plain-extra texlive-pstricks
texlive-pstricks-doc texlive-publishers texlive-publishers-doc
texlive-science texlive-science-doc texlive-xetex
Suggested packages:
fonts-noto perl-tk dvipng dvidvi xindy fragmaster purifyeps lacheck chktex
latexmk latexdiff libspreadsheet-parseexcel-perl libtcltk-ruby dot2tex
prerex
The following packages will be REMOVED:
fonts-droid
The following NEW packages will be installed:
fonts-droid-fallback fonts-noto-mono fonts-roboto fonts-roboto-hinted
irqbalance libfile-homedir-perl libfile-which-perl libpotrace0 libsynctex1
libtexlua52 libtexluajit2 libzzip-0-13 texlive-binaries texlive-extra-utils
texlive-font-utils texlive-fonts-recommended texlive-generic-recommended
texlive-lang-european texlive-latex-base
The following packages will be upgraded:
libkpathsea6 libptexenc1 tex-common texlive-base texlive-latex-base-doc
texlive-latex-extra texlive-latex-extra-doc texlive-latex-recommended
texlive-latex-recommended-doc texlive-luatex texlive-metapost
texlive-metapost-doc texlive-music texlive-omega texlive-pictures
texlive-pictures-doc texlive-plain-extra texlive-pstricks
texlive-pstricks-doc texlive-publishers texlive-publishers-doc
texlive-science texlive-science-doc texlive-xetex
24 upgraded, 19 newly installed, 1 to remove and 370 not upgraded.
7 not fully installed or removed.
Need to get 0 B/928 MB of archives.
After this operation, 333 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 453869 files and directories currently installed.)
Preparing to unpack .../texlive-latex-base-doc_2015.20160320-1ubuntu0.1_all.deb ...
Unpacking texlive-latex-base-doc (2015.20160320-1ubuntu0.1) over (2013.20140215-1ubuntu0.1) ...
dpkg: error processing archive /var/cache/apt/archives/texlive-latex-base-doc_2015.20160320-1ubuntu0.1_all.deb (--unpack):
trying to overwrite '/usr/share/doc/texlive-doc/latex/url/miscdoc.sty', which is also in package texlive-latex-recommended-doc 2013.20140215-1ubuntu0.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/texlive-latex-base-doc_2015.20160320-1ubuntu0.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)