Trisquel NOTIFICATION problem

9 replies [Last post]
iShareFreedom
Offline
Joined: 12/20/2021

Trisquel by default dont have notification sound program, that mean programs like gajim, hexchat and others can be affected and dont work properly in Trisquel (MATE)

prospero
Offline
Joined: 05/20/2022

I believe you should be able to set the volume for audio notifications through Control Center > Sound > Sound Effects tab. Make sure that "Alert volume" is not muted and that "Enable window and button sounds" is checked. Also, make sure a theme is selected.

This works for me on Trisquel 10.0.1 Nabia, although I usually keep sound effects muted. Not sure what the default settings are.

iShareFreedom
Offline
Joined: 12/20/2021

Yes, the problem is solved anyway i dont know how, but now works perfectly thanks prospero, anyway you know how to modify the notifications? the theme of the notifications in trisquel? with Notification Config of MATE i cant change nothing, looks bug

prospero
Offline
Joined: 05/20/2022

If the picture below is what you are talking about, then I am experiencing the same situation: changes made in either dconf or the Notifications GUI have no effect.

https://screenshots.debian.net/package/mate-notification-daemon#gallery

No idea what the back-end is supposed to be, never needed to change the default settings.

iShareFreedom
Offline
Joined: 12/20/2021

Yes, im speaking about the mate-notification-daemon

prospero
Offline
Joined: 05/20/2022

I would think most users just never noticed that bug, because the default behavior works fine.

You may get more info looking at your logs, clearly the GUI input is not properly getting sent to the backend, for whatever reason. I could not find any config files, only theme files, so either the default theme is hard coded, or I did not look at the right place.

EDIT: This commit possibly fixed the problem in MATE 1.26, and thus hopefully for Trisquel 11:
https://github.com/mate-desktop/mate-notification-daemon/pull/196/commits/7d081a0fceea882ad01fe34f9efc54584d6a1183

iShareFreedom
Offline
Joined: 12/20/2021

I dont know how apply that commit in my Trisquel GNU

prospero
Offline
Joined: 05/20/2022

You need to recompile mate-notification-daemon with the modified source file, or wait until you can upgrade to Trisquel 11 and it will most probably have been done for you.

If you would like that fix to be available in Trisquel 10 Nabia, you need to report the bug, or even better to discuss it first on the #trisquel libera.chat IRC channel. This is an upstream bug, so you may report to MATE instead and ask there if the 1.26 fix can be backported to 1.24:

https://github.com/mate-desktop/mate-notification-daemon/issues

prospero
Offline
Joined: 05/20/2022

[wrong indent]

iShareFreedom
Offline
Joined: 12/20/2021

I fix the notification popup problem of trisquel removing the package called notify-osd

so, sudo apt remove notify-osd or in synaptic.