Trisquel Unstable?

42 replies [Last post]
Beko
Offline
Joined: 08/31/2019

Is there a Trisquel unstable with newer packages similar to Debian Sid? I've tried to install Parabola for newer packages, but it's too hard and I'm afraid I'll brick my Bios if I start changing stuff in GRUB.

jxself
Offline
Joined: 09/13/2010

You can try Trisquel 9 but be careful. Is there something specific you need beyond just "newer packages"? Because these packages in Trisquel 8 still work.

Beko
Offline
Joined: 08/31/2019

I believe every package in Trisquel 8 is LTS and they do indeed work, but some features are missing. When trying to diagnose something I end up needing a newer version, but I don't wholly trust debs even from the official websites.

I've seen the Trisquel 9 code page on http://archive.trisquel.info/trisquel/dists/etiona/
but I have no clue how to derive an iso from here.

evilive
Offline
Joined: 08/12/2019

What do you mean, that you can make the newer packages work in Trisquel 8, or that it has the packages (albeit older versions) that "still work" in the same way as the newer ones?

MD. SHAHIDUL ISLAM
Offline
Joined: 10/14/2015

I am using trisquel 9 and I am happy with it. Some packages are missing from repos.

Beko
Offline
Joined: 08/31/2019

Do you know how I can get the iso for Trisquel 9?

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> Do you know how I can get the iso for Trisquel 9?

There is none yet. I think that we are close to having a netinstall
image ready, but progress is slow. For now, I can think of three ways to
install Trisquel 9:

* debootstrap: This is probably the "right way" but not the most
beginner friendly one.

* Upgrade from Trisquel 8: I've tested upgrading from a fresh, minimal
install of Trisquel 8 and it worked fine. Upgrading from a system with
more packages installed might or might not work well depending on what
you have installed. See here[1] to see which packages are currently
still broken in Trisquel 9.

* Migrate from Ubuntu 18.04: I haven't tested this at all, and I don't
recommend it for now. Among other things that could go wrong, I don't
think that all of Trisquel's branding and artwork has been package for
Etiona yet, which shouldn't be a problem upgrading from Trisquel 8
since the artwork will already be installed on your system, but would
be a problem when migrating from Ubuntu since Ubuntu's
artwork/branding will need to be replaced.

[1] https://trisquel.info/en/wiki/status-package-helpers-etiona

evilive
Offline
Joined: 08/12/2019

hi chaosmonk, perhaps you know what DE will be the default one in Trisquel 9 Mini? Wiki says it's lxqt, is this true? Will lxde be dropped?

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> hi chaosmonk, perhaps you know what DE will be the default one in
> Trisquel 9 Mini?

This hasn't come up in any meetings I was present for, so I'm not sure.

> Wiki says it's lxqt, is this true? Will lxde be dropped?

Can you link to the wiki page you're referring to?

evilive
Offline
Joined: 08/12/2019

I mean, Wikipedia. Trisquel's page says "Default user interface: LXQt and MATE (9.0 or above)". It would be saddening if they dropped LXDE. Tell them they needn't next time you meet them. :)

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

In the longer term, most Razor-qt components will fully be integrated into the LXDE-Qt and both teams will focus on the same project. Looking further ahead, the GTK version of LXDE will be dropped and all efforts will be focused on the Qt port.
https://blog.lxde.org/2013/07/22/the-future-of-razor-and-lxde-qt/ (notice the date)

LXDE-Qt was then rename LXQt: https://blog.lxde.org/2014/04/27/the-first-alpha-release-of-lxde-qt-or-lxqt-is-in-preparation/

evilive
Offline
Joined: 08/12/2019

as far as I know, LXDE and LXQt are separate desktops. Maybe LXDE is no longer actively developed, but it's still separate. (anyway, whether it's officially "developed" or not doesn't matter all that much as long as its maintenance is routinely carried out, because it has an active and devoted userbase that's quite large)

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> In the longer term, most Razor-qt components will fully be integrated
> into the LXDE-Qt and both teams will focus on the same project.
> Looking further ahead, the GTK version of LXDE will be dropped and all
> efforts will be focused on the Qt port.

Hm. It looks like Ubuntu is still packaged in Ubuntu as of 18.04,[1] and
Lubuntu did not switch from LXDE to LXQt until 18.10,[2] so we should be
able to use LXDE for Trisquel Mini 9 if we want to, but for Trisquel
Mini 10+ that might no longer be an option.

[1] https://packages.ubuntu.com/bionic/lxde
[2] https://en.wikipedia.org/wiki/Lubuntu#Lubuntu_18.04_LTS

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> I mean, Wikipedia. Trisquel's page says "Default user
> interface: LXQt and MATE (9.0 or above)".

I just brought this up at the meeting. quidam does not recall discussing
LXDE vs LXQt. I don't know where the Wikipedia info came from, since
there's not citation. I don't think dropping LXDE is something we'll
need to consider until Trisquel 10.

evilive
Offline
Joined: 08/12/2019

Good to hear, thanks for clarifying it.

Beko
Offline
Joined: 08/31/2019

When trying to install Trisquel 8 netinstall, is there anything special that needs to be done? I had been doing

'Sudo dd if=~/Downloads/Trisquel-netinstall of=/dev/sdb bs=1M; sync'

When trying to boot from parse isolinux usb in libreboot it doesn't recognize usb. Works fine with both Trisquel 8 - mate and Trisquel 8 - mini, also tested both out GUI and text mode. Do I have to go to the GRUB cli to do netinstall?

I'm trying to do the second method that you stated with absolute minimum Trisquel install before changing repository sources.

Thanks!

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> 'Sudo dd if=~/Downloads/Trisquel-netinstall of=/dev/sdb bs=1M; sync'

The only thing that looks off to me (apart from the capital "S" in
"Sudo" which I assume is just a typo in the forum post) is the file name
"Trisquel-netinstall". It should be something like
"trisquel_8.0_amd64.iso". Where did you get this file? Did you rename it
to something without a file extension yourself?

Beko
Offline
Joined: 08/31/2019

Sorry! When I wrote Trisquel-netinstall i simply meant netinstall as opposed to mate or mini. I'm usually pressing tab to autofinish the name of the iso (after checking with gpg, of course) so I only had .asc .iso and .gpg files in downloads. I didn't have the exact name of the iso as I had deleted it and didn't bother to redownload just to check the name.

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> Sorry! When I wrote Trisquel-netinstall i simply meant netinstall as
> opposed to mate or mini. I'm usually pressing tab to autofinish the name
> of the iso (after checking with gpg, of course) so I only had .asc .iso
> and .gpg files in downloads. I didn't have the exact name of the iso as I
> had deleted it and didn't bother to redownload just to check the name.

Okay, no problem. Well, here's the iso I know works.
https://trisquel.info/en/forum/setting-server#comment-141899

Beko
Offline
Joined: 08/31/2019

I'm getting 404 not found on the link beginning with jenkins.trisquel.info could you verify if the link is working for you?

Edit: going through the directories I found another netinstall at -

jenkins.trisquel.info/makeiso/iso.old/trisquel-netinst_8.0-20190326_amd64.iso

I believe the iso might have been moved from the directory that you had linked, I'm going to test this one out.

Edit2: also did not work..

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> I'm getting 404 not found on the link beginning with
> jenkins.trisquel.info could you verify if the link is working for you?

Crap, it's gone. Okay, a netinstall is not possible at this time. I'll
bring this up at Friday's meeting.

MD. SHAHIDUL ISLAM
Offline
Joined: 10/14/2015

At first I install trisquel-8-mini. Then run: $ sudo apt update.
After updating: editing
/etc/apt/sources.list and changing "flidas" to "etiona",
and running:
$ sudo apt update
$ sudo apt install perl-modules-5.26 # to resolve a package conflict when upgrading
$ sudo apt upgrade
$ sudo apt dist-upgrade

paolo
Offline
Joined: 08/02/2017

hello I follow your instruction on a new trisquel mini installation but after a reboot
lightdm doesn't start. there is a way to repair it please?

Beko
Offline
Joined: 08/31/2019

Is lightdm the login screen? Because I've also gotten stuck after decrypting the system.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Yes, by default on Trisquel, LightDM displays the graphical login screen.

paolo
Offline
Joined: 08/02/2017

Solved! Now I have Trisquel Mini 9 up and running on my netbook :)
I made a fresh install of Trisquel Mini 8 whitout encryption and with the access to Lxde without put the password in Lightdm.
I follow the instructions to upgrade by MD. Shahidul Islam and now I have Trisquel Mini 9 Etiona! In the next days I made many text to use and configure.
I have one question, the Grub is now "invisible" how can I configure to have it back?

IMG_20191027_184239~01.jpg
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

You need to edit, with administrative permissions, /etc/default/grub ('gksu pluma /etc/default/grub', if you like Pluma) and then execute 'sudo update-grub'. See https://www.gnu.org/software/grub/manual/grub/html_node/Simple-configuration.html for the meanings of /etc/default/grub's variables. I believe Etiona's GRUB is recent enough to know about the new GRUB_TIMEOUT_STYLE variable.

paolo
Offline
Joined: 08/02/2017

many thanks pal,
I read on your link, to see Grub simply I can press ESC without modify anything.
If I resolve some small problems maybe Etiona can be my daily driver.
First problem: it seems Lightdm is not installed, but Synaptic says Lightdm is installed. Do you have the same problem?

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> First problem: it seems Lightdm is not installed, but
> Synaptic says Lightdm is installed. Do you have the
> same problem?

Is lightdm-gtk-greeter installed? (Tip: you might find it faster to run

$ apt policy lightdm-gtk-greeter

than to open up and look through synaptic.)

paolo
Offline
Joined: 08/02/2017

thanks @chaosmonk I try this evening when I come home from work.

Out of curiosity: someone here use Trisquel 9 as a daily driver? or only for test?
Trisquel Mini 8 for me is absolutely the best

Edit: is not possible to install lightdm-gtk-greeter, the package is missing, and also abiword is missing too...
what if I "take" the packages from Flidas? maybe changing synaptic sources or from some ppa?
... is just a question, I am totally after many years of GNU/Linux... I think to go back to Flidas Mini (the best O.S. in years)

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> is not possible to install lightdm-gtk-greeter, the package is missing, and also abiword is missing too...

I see, these packages have not yet been pushed to the repo.

> what if I "take" the packages from Flidas?

I would instead grab the Bionic debs from packages.ubuntu.com and install them manually (let me know if you do not know how to do this), so that the version match what will be in Etiona. I don't think that we will modify Ubuntu's version of abiword. We did modify it in Flidas, but only to address a bug which has been fixed upstream. Our version of lightdm-gtk-greeter will be a little different from Ubuntu's, but only for cosmetic purposes, not freedom issues, so it should be fine to use Ubuntu's version until Trisquel's is ready. Once it's in the repos, "apt update && apt upgrade" will replace Ubuntu's version with Trisquel's.

paolo
Offline
Joined: 08/02/2017

hello @chaosmonk I find https://packages.ubuntu.com/
I grab the file from here and I find there are others 13 .deb files to grab because only lightdm-gtk-greeter doesn't work.
I thank you (please don't be angry) but I think to go back to Flidas Mini

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> hello @chaosmonk I find https://packages.ubuntu.com/
> I grab the file from here

Yes, for example, get lightdm-gtk-greeter from here:

https://packages.ubuntu.com/bionic/lightdm-gtk-greeter

Click on your architecture, and download the deb. Install it with

$ sudo dpkg -i /path/to/file.deb

or graphically using gdebi. If you are missing dependencies you will
have to install those first. This is not an ideal way to install
software. It is better to use the package manager. However, if you
want to get lightdm working this is probably the quickest way until it
hits the Trisquel 9 repo.

Alternatively, you could use another display manager for now. Slim is
already in the repo:

$ sudo apt install slim

paolo
Offline
Joined: 08/02/2017

I have used gdebi, but Lightdm greeter doesn't open is config window.
The SliM project has been abandoned (last release was 2013 and is not fully compatible with systemd, including logind sessions.
Thank for your great help but tomorrow I go back ti Flidas Mini, now here is 3 o'clock :)

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> I have used gdebi, but Lightdm greeter doesn't open is config window.

So lightdm and lightdm-gtk-greeter are both installed, but it doesn't work? What happens? Black screen? TTY? Does startx work? Does slim work?

> The SliM project has been abandoned (last release was 2013 and is not fully compatible with systemd, including logind sessions.

The version in Etiona works, even with systemd (I briefly used it until I got LightDM working).

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> > The SliM project has been abandoned (last release was 2013 and is not
> fully compatible with systemd, including logind sessions.
>
> The version in Etiona works, even with systemd (I briefly used it until I
> got LightDM working).

GDM is in the repo too, though I haven't tested it yet.

paolo
Offline
Joined: 08/02/2017

> So lightdm and lightdm-gtk-greeter are both installed, but it doesn't work? What happens? Black screen? TTY? Does startx work? Does slim work?

when I light the netbook (eeepc 1001px) Trisquel Mini 9 start in 28 seconds and load LXDE, I don't need to use startx, during the system install I flag for the automatic login.
If I open the Lightdm settings from the Lxde menu I need to type my password and nothing happen.

From the terminal (is italian: installato means installed, candidato means candidate, tabella versione means version) :
lightdm-gtk-greeter:
Installato: 2.0.5-0ubuntu1
Candidato: 2.0.5-0ubuntu1
Tabella versione:
*** 2.0.5-0ubuntu1 100
100 /var/lib/dpkg/status

lightdm:
Installato: 1.26.0-0ubuntu1+9.0trisquel1
Candidato: 1.26.0-0ubuntu1+9.0trisquel1
Tabella versione:
*** 1.26.0-0ubuntu1+9.0trisquel1 500
500 https://archive.trisquel.info/trisquel etiona/main amd64 Packages
100 /var/lib/dpkg/status

sudo lightdm-gtk-greeter have this error:
(lightdm-gtk-greeter:1801): Gtk-WARNING **: 19:43:49.000: Theme parsing error: other-applications.css:377:23: The :insensitive pseudo-class is deprecated. Use :disabled instead.

I think is a theme error but now I want to try Slim

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

On 10/29, name at domain wrote:
> If I open the Lightdm settings from the Lxde menu I need to type my
> password and nothing happen.

That's a separate package: lightdm-gtk-greeter-settings. Make sure you
have that installed too.

paolo
Offline
Joined: 08/02/2017

>That's a separate package: lightdm-gtk-greeter-settings. Make sure you
have that installed too.

Yes it's installed, I understand my mistake
from the terminal I type :
sudo lightdm-gtk-greeter-settings and the window open and I can change my settings.

Also I have installed (and trying) Slim... both are very ugly...

I now switch back to Trisquel Mini 8, Etiona is a nice adventure for me but I miss the simply rock solid Flidas

knife
Offline
Joined: 01/02/2019

I got a WLAN Card which needs a Firmware that is Not included. In Startup etiona says that the Firmware can not ne loaded, wait and retry with no time Limit and CPU stucks.

I tried Recovery on startup and started Network manually and Ethernet works! ..
There is a message that says wlan Card will not work but Everything Else is Working.

Gnome-session-bin is not included yet?

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> I got a WLAN Card which needs a Firmware that is Not included. In Startup
> etiona says that the Firmware can not ne loaded, wait and retry with no
> time Limit and CPU stucks.

What is the firmware you need? Is it free?

knife
Offline
Joined: 01/02/2019

No, the Firmware isn't free, it also didnt Work with trisquel 8. I Never used the WLAN Card since I installed trisquel.
But a stucked cpu and Unlimited waiting over and ob er again is Not fine. About Every 22 seconds the Message Appears that the firmware is Not included. And a prompt Never appears..

Thats the Card i use:
HP 350 G2 WLAN Karte Wifi Card
753077-001

chaosmonk

I am a member!

I am a translator!

Offline
Joined: 07/07/2017

> No, the Firmware isn't free, it also didnt Work with trisquel 8. I
> Never used the WLAN Card since I installed trisquel.

I don't think non-free firmware will work with Trisquel's kernel. My
understanding is that Linux-libre cannot load non-free firmware. This
is not by design, but an unintentional side effect of suppressing error
messages that might "induce" the user to install non-free firmware.