Accidentally removed a panel icon and can't find it in order to add it back.

6 respostas [Última entrada]
Trisk Spellian
Joined: 03/20/2015

I had two different time icons in my panel. I liked one better than the other, so I decided to delete the one that comes standard at installation. Little did I know that it would also delete the Network Connection (showing my wired internet connection with VPN symbol) and Volume icons as well. When I look through all of the icon options to add to my panel none of them are the one I deleted.

I don't know what it's called or where it is, but it was the time, the volume, and the network connection all in one icon. I'm sure most of you have it on your panels.

Anyone know how to re-add it?


Joined: 02/29/2012

If you know how to add stuff to the panel try adding either the "Indicator Applet" or the "Indicator Applet Complete". I'm not certain which of the two you'd want but you can try either one and see which works for you.

Trisk Spellian
Joined: 03/20/2015

Thank you very much! That was just what I needed! I wish I had been more patient and waited for an answer before trying to "fix" it myself, because now I've messed things up further! I tried following some old instructions online and now I can't get or keep a panel at all. And I'm afraid I may have done other unknown bad things.

Here's what I did.

I tried following these instructions:

and these:

Note, I didn't quite do that in order. The first thing I did (on accident) was to remove the .gconf directory. I did back it up, the one wise thing I did. Then I issued the commands

~$ gconftool --recursive-unset /apps/panel
~$ pkill gnome-panel

That only blinked the panel off for a second and back. So I tried

~$ gconftool-2 --shutdown
~$ pkill gnome-panel

That resulted in the same. Then I got the bright idea to issue the command

~$ gnome-panel --replace

And now the only way I can get a panel to stay up is to issue that command in the terminal. It gives me this output beneath

(gnome-panel:15581): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gsignal.c:2462: signal 'size_request' is invalid for instance '0x2ace1c0' of type 'GtkLabel'

and the panel will appear, but my command prompt is gone and if I hit ctrl + c the panel disappears again.


I thought I had long ago given up on making boneheaded noob mistakes, but I guess not.

So, my question now becomes did I shutdown anything else? What exactly have I done to my system? I do I get things back to "normal?"

Thanks again!!

Trisk Spellian
Joined: 03/20/2015

Okay, so I managed to get my panel back thankfully, and I'm pretty sure I didn't cause any lasting damage to my system.

I got lucky and stumbled across this response by Chris:

That brought my panel back to its system default state... which is fine by me!! No big deal to have to recustomize it. I'm just happy it's there. I rebooted as well to make sure it will show up without having to manually put it there or anything, and it does.

I'm still a little worried that my gconftool-2 --shutdown command did something bad to something else unrelated to the panel. Hopefully rebooting the computer "fixed" whatever I may have shutdown. I don't know. If anybody sees anything bad by what I did above please let me know. I think I'll go on assuming everything is good from this point on.


I am a translator!

Joined: 10/31/2014

He he :) This reminds me the first time I installed a GNU distro on my laptop. I messed it up so badly that it wasn't able to boot at all in the record time of 40 or 50 minutes...
That taught me the golden rule (which unexpectedly is not "he who has the gold makes the rule") of GNU -> If you don't know what you are doing, don't do it, read and study the topic before doing anything at all!
Glad you solved it Trisk Spellian.

Joined: 04/15/2015

May I add a divergent tangental question here? Briefly, I had the panel problem twice recently. I could get to almost everything (not the software store) by round abouts and I also learned more about terminal. After a week or so in each case the panel came back as mysteriously as it disappeared.

Now, though, I have a "cloud cover" sitting over my desktop and no direct access to my home folder contents. I have to open a jpeg viewer or text app to then open a document. Is there a terminal command to get my desktop and home folder functions back?

Magic Banana

I am a member!

Joined: 07/24/2010

Try to execute the following command from a virtual terminal and tell us what happened:
$ nautilus