Ayuda con el códec AV1

3 respostas [Última entrada]
andi_rivera
Desconectado
Joined: 06/11/2019

Buen día, recientemente he comenzado a tener problemas al repoducir videos en mi navegador [ABrowser] debido al códec AV1; en otra PC que utilizao en la casa, en la cual tengo instalado Kubuntu 18.04, navego con Chome y no tengo problemas para la reproducción del mencionado códec, el cual, por cierto cada vez se utiliza con más frecuencia en YouTube, canal al que accedo con regularidad por cuestiones laborales.

¿Alguna sugerencia?.

Muchas gracias :)

PJJ
PJJ
Desconectado
Joined: 08/27/2018

¡Buenas andi!.

- Si mal no recuerdo el códec AV1 no es Software Libre y la FSF no lo apoya por algunos inconvenientes con algunas licencias, sólo es Open-Source por eso no lo encontrarás en Trisquel o en Abrowser, en Kubuntu si lo encuentras porque la gran parte de distros admiten software Open-Source y Privativos saltándose así el proyecto de GNU, si lo que quieres ver es vídeos en Abrowser, aquí te dejo una página alternativa a Youtube, es lo mismo, no tendrás problemas.

https://www.invidio.us/

¡Un abrazo!.

Moskito256
Desconectado
Joined: 05/08/2019

Esto es extraño ¿Qué canales/videos te causan problemas? Yo uso youtube todos los días y no me he topado con algún problema del códec AV1.

Por cierto, no hay una diferencia esencial entre el software libre y open-source, más allá del nombre y la filosofía que está detrás, excepto quizás por el copy-left (que afecta al software derivado y no al original). Aún así, las licencias de open-source en general son compatibles en gran medida con las GPL, así que en ese sentido no debería haber problemas.

eliotime3000
Desconectado
Joined: 06/05/2016

El chiste está si tienes bien configurado el Gstreamer, el cual es el principal soporte para que el navegador sea capaz de soportar buena parte de los códecs que usan las páginas web en cuanto a videos en HTML5.

Y de acuerdo a la ayuda que brinda Debian en cuanto a otro problema parecido (es decir, con el códec H.264), la solución es ésta:

apt-get install gstreamer1.0-libav gstreamer1.0-plugins-good

Yo añadiría las variantes de plugins-bad y plugins-ugly para gstreamer1.0, por lo que recurriría a la biblioteca de drivers que tiene FFMPEG para reproducir esa clase de códecs y así evitarme esos problemas (o que en YouTube, el Abrowser fuerce a que consulte los videos pero en VP9, cosa que ocurre en Iceweasel de Parabola).

Y un consejo más:

"Asegúrate que en los parámetros de about:config esté la opción media.peerconnection.video.h264_enabled configurada en true".

Fuente: Wiki de Firefox ESR de Debian (antes, Iceweasel) >> https://wiki.debian.org/Iceweasel#No_H.264_support_in_youtube