Can't log in

13 respostas [Última entrada]
GNUbahn
Desconectado
Joined: 02/18/2016

After trying Flidas/T8.0 for a while I just replaced it with Belenos/T7.0.

Now I can't log in.

I believe I used same computer name, username and password.

Any ideas on how to solve this situation?

GNUbahn
Desconectado
Joined: 02/18/2016

I just noticed: If I type ewrong password, I am met with a message saying that username or passwrod is unknown. So it does register my password to be correct for the username. Still I am not logged in.

GNUbahn
Desconectado
Joined: 02/18/2016

I tried to reinstall Belenos (a couple of times) but the problem stayed the same. After reinstalling Flidas, I can log in.

I would like to downgrade to Belenos though. Why am I having this problem?

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

Can you log in the terminal you get by pressing Ctrl+Alt+F1 after the init (it is normal no character is shown while typing the password)? If so, the problem deals with X server. Maybe it configures a layout for the keyboard that is different than yours: type your password as if it was the name of the user who wants to log in (hence shown to you). Or that layout was wrong in Trisquel's installer and you can try the substitution between your layout and the default American layout (I guess it is the default).

If all that fails, follow the instructions in https://trisquel.info/forum/locked-out-admin-log#comment-105213

GNUbahn
Desconectado
Joined: 02/18/2016

There is no issue with the keyboard configuration. I can log in after pressing Ctrl+Alt+F1 but not without issues.

After the 'Welcome to Trisquel GNU/Linux 7.0, Belenos (GNU/Linux 3.13.0-39-lowlatency x86_64)' and the '3D' TRISQUEL graphics, I get

Welcome to Trisquel GNU/Linux
Documentation: http://trisquel.info/wiki/
Signature not found in user keyring
Perhaps try the interactive 'ecryptfs-mount-privat'
gnubahn@libreT400s:~$

The tilde in the last line is actually placed at the top (I don't know it that is significant)

One guy suggested this:

ecryptfs-rewrap-passphrase /home/.ecryptfs/$USER/.ecryptfs/wrapped-passphrase https://askubuntu.com/questions/411702/ubuntu-12-04-keyring-broken-signature-not-found-in-user-keyring-perhaps-try-the

Does that sound sensible?

GNUbahn
Desconectado
Joined: 02/18/2016
Ignacio.Agullo
Desconectado
Joined: 09/29/2009

On 16/09/17 19:04, name at domain wrote:
> Though I don't speak or read Spanish, this guy seems to agree:
> http://hluisgarcia.es/wordpress/2015/08/signature-not-found-in-user-keyring-perhaps-try-the-interactive-ecryptfs-mount-private/

I make a quick translation from this article from 2015: this Ubuntu
user encrypted his user folder. He says that in Ubuntu the password for
the encrypted user folder it's the user password, so there should be no
problem - but it seems that he entered the password during the
installation with a different keyboard configuration. He changed the
user password later, but his user folder was already encrypted with the
first password. He finally solved the problem with this command:

|ecryptfs-rewrap-passphrase
/home/.ecryptfs/$USER/.ecryptfs/wrapped-passphrase This command asks for
the old password once and for the new password twice, and then
re-encrypts. |

--
Ignacio Agulló · name at domain

GNUbahn
Desconectado
Joined: 02/18/2016

Gracias!

That does not seem to be identical to my problem then.

GNUbahn
Desconectado
Joined: 02/18/2016

BTW, can it be related to the fact that I was running Cinnamon, which is not installed (yet)?

GNUbahn
Desconectado
Joined: 02/18/2016

As suggested by the message from tty1 I ran the 'ecryptfs-mount-privat' command and was prompted for my login passphrase. It returns:

Error: Unwrapping passphrase and inserting into the user session keyring failed [-5]
Info: Check the system log for more information from libecryptfs
ERROR: Your passphrase is incorrect

And I get the option to enter my passphrase again

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

The password to decrypt your data is different from that of your account. You chose an encrypted home folder by checking the related box in Trisquel installer, right? Any weird character in your password?

GNUbahn
Desconectado
Joined: 02/18/2016

You chose an encrypted home folder by checking the related box in Trisquel installer, right?Yes

Any weird character in your password?No

GNUbahn
Desconectado
Joined: 02/18/2016

I also tried the passprase generated by luks, but it's not that either...

GNUbahn
Desconectado
Joined: 02/18/2016

I 'solved' this my backing up my home files and reinstall T7.0 while overwriting home as well, and copying the backed up files to the new home.