DNI electrónico

5 respostas [Última entrada]
neovsmith
Desconectado
Joined: 08/15/2008

Hola a todos.

Quisiera preguntarles a los administradores de la distro, si tienen planes para incorporar al repositorio el módulo criptográfico necesario para utilizar el dni electrónico. El que publican en la página oficial del dni-e esta compilado para Ubuntu Lucid y no consigo que funcione.

Un saludo a todos y gracias de antemano.

Eduardo Saavedra-D'Attellis
Desconectado
Joined: 08/06/2009

No te funcionó con Trisquel 4.0 taranis?

Eduardo Saavedra-D'Attellis
El 25/08/2011 15:43, <name at domain> escribió:
> Hola a todos.
>
> Quisiera preguntarles a los administradores de la distro, si tienen planes

> para incorporar al repositorio el módulo criptográfico necesario para
> utilizar el dni electrónico. El que publican en la página oficial del
dni-e
> esta compilado para Ubuntu Lucid y no consigo que funcione.
>
> Un saludo a todos y gracias de antemano.

Daniel Molina
Desconectado
Joined: 07/04/2009

Oi una vez que habia una parte privativa que era ineludible.

neovsmith
Desconectado
Joined: 08/15/2008

Hola Daniel.

En la pàgina oficial www.dnielectronico.es aparece, en su área de descargas, una referencia al proyecto "opendnie" que, por lo menos en teoría, es libre. Dicho proyecto no publica paquetes precompilados por lo que hay que hacer una compilación para tu sistema. A mi no me preocupa hacer una compilación pero, debido a mis limitados conocimientos, no se como se comportaría el sistema con las sucesivas actualizaciones de "Slaine". Por ello, me parece que la opción más estable es que se incluya en el repositorio un paquete al respecto, ya sea basado en el módulo oficial o en el de opendnie.

Un saludo.

Eduardo Saavedra-D'Attellis
Desconectado
Joined: 08/06/2009

En este post hablan de una instalación de ubuntu 10.10 con la utilización
requerida de paquetes de la versión 10.04
http://bitplanet.eu.org/manuales/3-linux/319-instalar-lector-dnie-en-ubu...
--
Eduardo Saavedra-D'Attellis

El 27 de agosto de 2011 12:18, <name at domain> escribió:

> Hola Daniel.
>
> En la pàgina oficial www.dnielectronico.es aparece, en su área de
> descargas, una referencia al proyecto "opendnie" que, por lo menos en
> teoría, es libre. Dicho proyecto no publica paquetes precompilados por lo
> que hay que hacer una compilación para tu sistema. A mi no me preocupa hacer
> una compilación pero, debido a mis limitados conocimientos, no se como se
> comportaría el sistema con las sucesivas actualizaciones de "Slaine". Por
> ello, me parece que la opción más estable es que se incluya en el
> repositorio un paquete al respecto, ya sea basado en el módulo oficial o en
> el de opendnie.
>
> Un saludo.
>

neovsmith
Desconectado
Joined: 08/15/2008

Hola Eduardo.

Solo lo he probado con Slaine y el síntoma que se me presenta es que, al introducir el dni-e en el lector, no aparece insertado en ninguna unidad, real o virtual, del módulo criptográfico que aparece en preferencias-opciones avanzadas-cifrado-dispositivos de seguridad. Por el contrario, en el terminal si aparece al ejecutar un pcsc_scan, y muestra los datos del dni-e. La conclusión a la que llego es que hay un problema con dicho módulo, de ahí la pregunta del hilo, puesto que la siguiente salida de terminal parece corroborarlo.

traballo@terra:~$ opensc-tool --info
opensc 0.11.13 [gcc 4.4.5]
Enabled features: zlib iconv openssl openct pcsc(/lib/libpcsclite.so.1) nsplugin
[opensc-tool] ctx.c:367:load_dynamic_driver: dynamic library '/usr/lib64/libopensc-dnie.so': invalid module version
[opensc-tool] ctx.c:467:load_card_drivers: Unable to load 'dnie'.
traballo@terra:~$

Un saludo.