Enigmail won't install

6 respostas [Última entrada]
GNUbahn
Desconectado
Joined: 02/18/2016

I have tried several times (on different computers times etc.) to install icedove and afterwards enigmail. When trying t install the latter, I get the message

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
enigmail : Depends: thunderbird (>= 38.0) or
seamonkey (>= 2.35) but it is not installable
E: Unable to correct problems, you have held broken packages.

Mangy Dog

I am a member!

I am a translator!

Desconectado
Joined: 03/15/2015

fix your broken packages in Synaptic and re-install
--
Synaptic>Edit>Fix Broken Packages
--
or
$ sudo apt-get install -f

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

I do not think it has anything to do with broken packages. It looks like a bug: Enigmail's package in Trisquel 7's repository should depend on "thunderbird or seamonkey or icedove" but the "or icedove" part is missing and the repository has neither "thunderbird" nor "seamonkey".

Mangy Dog

I am a member!

I am a translator!

Desconectado
Joined: 03/15/2015

True , i did find that odd..

btw you need to install gnupg2 (from memory it is not installed by default)

albertoefg
Desconectado
Joined: 04/21/2016

Why not downloading enigmail directly?

https://www.enigmail.net/index.php/en/download-old-versions

GNUbahn
Desconectado
Joined: 02/18/2016

Solved!

Mangy Dog's comment made me remember that the solution has earlier been related to gnupg2. I can't remember how exactly I solved the problem earlier. but now it works.

Strangely though, after I installed gnupg2, Icedove worked with Enigmail. Recall, that when trying to install Enigmail in the first place, I got the message of the OP.

And if I run the same command, I get the same message. I should have had one saying

Reading package lists... Done
Building dependency tree
Reading state information... Done
icecat is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I wonder why?

Mangy Dog

I am a member!

I am a translator!

Desconectado
Joined: 03/15/2015

Enigmail requires gnupg2 since version v.19
https://www.enigmail.net/index.php/en/faq?view=topic&id=13