Get back to Trisquel...

3 respostas [Última entrada]
marioger
Desconectado
Joined: 11/20/2011

I just install gNewSense and when it asked where to install Grub, i choose to install it in my sda partition. Now when i start my computer i can see something like "Loading stage 5..." and i have no menu to choose Trisquel...

I did a :

~$ sudo update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.24-30-generic
Found kernel: /boot/vmlinuz-2.6.24-24-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

It didn't find my other OS ??

Then i did a :
cat /boot/grub/menu.lst

title gNewSense GNU/Linux 2.3 (deltah), kernel 2.6.24-30-generic
root (hd1,1)
kernel /boot/vmlinuz-2.6.24-30-generic root=UUID=1081c334-3132-4cd5-b7a0-119d86c52830 ro quiet splash
initrd /boot/initrd.img-2.6.24-30-generic
quiet

title gNewSense GNU/Linux 2.3 (deltah), kernel 2.6.24-30-generic (recovery mode)
root (hd1,1)
kernel /boot/vmlinuz-2.6.24-30-generic root=UUID=1081c334-3132-4cd5-b7a0-119d86c52830 ro single
initrd /boot/initrd.img-2.6.24-30-generic

title gNewSense GNU/Linux 2.3 (deltah), kernel 2.6.24-24-generic
root (hd1,1)
kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=1081c334-3132-4cd5-b7a0-119d86c52830 ro quiet splash
initrd /boot/initrd.img-2.6.24-24-generic
quiet

title gNewSense GNU/Linux 2.3 (deltah), kernel 2.6.24-24-generic (recovery mode)
root (hd1,1)
kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=1081c334-3132-4cd5-b7a0-119d86c52830 ro single
initrd /boot/initrd.img-2.6.24-24-generic

title gNewSense GNU/Linux 2.3 (deltah), memtest86+
root (hd1,1)
kernel /boot/memtest86+.bin

quiet

My actual hdd are like this:

hd1: sda1 debian and sda2 DATA
hd2: sdb1 trisquel sdb2 NewSense sdb3 swap

What could i do?

I know its noob. I always having problem with Grub.

lembas
Desconectado
Joined: 05/13/2010

I think the problem happens because of different grub versions. That output comes from grub-legacy while Trisquel (since version ?) and debian (since version 6) uses grub2 aka grub.

Perhaps change one of the entries so it boots to say Trisquel and then try setting up grub from there. It just might be backwards compatible.

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

From the gNewSense system, I would 'mount' Trisquel's root filesystem,
'chroot' in it and 'update-grub' from there. Take a look at this
documentation.

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

From the gNewSense system, I would 'mount' Trisquel's root filesystem, 'chroot' in it and 'update-grub' from there. Take a look at this documentation.