Icedove - can't open attachments

4 respostas [Última entrada]
Joined: 02/19/2016

This seems to be a long solved issue, since answers I have found on the net are quite old. and none of the answers I have found solve the problem in my case.

And this is a 'new' problem that has turned up today. I can't remember exactly the last time I opened an attachment, but it can't that long.

Anyway, when I click on the attachment I see the usual bow to choose if I want to save the file or open it with the appropriate program (i.e. okular for pdf, writer for odt, doc etc).

When I choose I get a new dialogue box (I translate from Danish, it might be open application).

From here I again have to choose which programme should open the attached file. Since this dialogue opens on my desktop, I have no idea of how to choose the appropriate application. And it shouldn't be necessary, since I have already chosen that in the settings of Icedove.

What am I overlooking?

Joined: 12/31/2012

I was trying to get description of the issue from your message, but I
don't understand, from your message, which file you are trying to open,
what application you want to open it with, and what happens
actually/currently (and if that application is presented as an option
inside "open with").

Can you please clarify the situation?

- [[]]
- Palestrante e consultor sobre /software/ livre (não confundir com
- "WhatsApp"? Ele não é livre, por isso não uso. Iguais a ele prefiro
GNU Ring, ou Tox. Quer outras formas de contato? Adicione o vCard
que está no endereço acima aos teus contatos.
- Pretende me enviar arquivos .doc, .ppt, .cdr, ou .mp3? OK, eu
aceito, mas não repasso. Entrego apenas em formatos favoráveis ao
/software/ livre. Favor entrar em contato em caso de dúvida.

Joined: 02/19/2016

Thanks for your response.

An example: I just received an email with a pdf-file attached to it. When I click the pdf-file I get the usual dialogue asking me if I want to open the file with a (pre-) chosen application or to save it. The pre-chosen application is okular. When I mark [open with okular (standard)] and click [ok] a new dialogue opens, asking to me to choose the application to open the file with.

This is of course not correct behaviour, since okular should just open the file.

Mangy Dog

I am a member!

I am a translator!

Joined: 03/15/2015

You can modify the behavior of how or which application handles attachement in Icedove via

Icedove >Preferences > Attachments (Outgoing/Incoming)

As in your ~ /home/ if you have a pdf document, picture, video you can also choose by >right click > open with the application you want

Joined: 02/19/2016

Thanks. I had already tried that. The settings were fine, and like I wrote, I was met with the appropriate pre-choce. But for some reason it still didn't work.

I have 'downgraded' back to Belenos and now it works