Sparse file issue w/KVM

1 reply [Última entrada]
Joined: 10/10/2017


I've installed KVM and and everything is fine. I've been trying to create a VM with Whonix OS. I am having some issues with the file size when I run:

tar -xvf ~/Whonix-Gateway-*.libvirt.xz


tar -xvf ~/Whonix-Workstation-*.libvirt.xz

When I run these commands, it eventually errors out and tells me I'm out of space. I am not sure why since I have over 100GB on the partition. So I checked the size of the qcow2 file, and it's 100GB!

I asked this question on the Whonix forum, but they said they believe it is a host operating issue (Trisquel 7) with sparse files.

Any ideas?

(These are the instructions I've been following FYI:

Joined: 08/13/2014


I have never used Whonix, and I have some experience with KVM, but I use it without libvirt.

How are you checking “the size” of the file? What is the output of the command (copy and paste it here or upload it as an attachment)?

If you use “ls -l”, this will tell you the logical file size. This is not necessarily the same as the space it uses on the file system. In particular, sparse files can use much less space than the size reported by “ls -l”.

Use “du --si FILE” (where “FILE” is the path to the file you want to examine) to know the approximate amount of space it is using on the file system; if this command gives around 100 GB then you know that the file is not being created as sparse; the next step would be to investigate further this problem; else you will have to continue looking for the source of the problem elsewhere.

Are you sure that you have enough space in the filesystem to extract those files? Use “du --si” to check that.