Trisquel 8: Lightning for Icedove

1 reply [Última entrada]
GNUbahn
Desconectado
Joined: 02/19/2016

I have installed T8 on two computers. On one I ran 'do-release-upgrade', on the other I did a fresh install (because 'do-release-upgrade' didn't work).

On the fresh installation, lightning/calendar works with Icedove.

On the one upgraded from T7 I can't get Lightning to work. When searching via add-ons in Icedove, I don't get an 'add' option, but rather a link to download the package. Since I would like my package manager to automatically update the add-on, I tried to install it via apt:

$ sudo apt install lightning
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
lightning : Depends: thunderbird (>= 1:45.8.0-3~deb7u1+8.0trisquel1)
E: Unable to correct problems, you have held broken packages.

With no luck.

What am I doing wrong, and why does Lightning work on the freshly installed T8 and not the upgrade one?

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

Try installing xul-ext-lightning instead.