Usb mobile modem and Trisquel 8

10 respostas [Última entrada]
Stallman rules
Joined: 08/10/2019

Usb 4G modem and Trisquel 8

a librebooted lenovo T400 computer.
installed Trisquel 8 the graphic way from iso dvd.

then plug-in a huawei usb modem and installing
software through software updater online.
and i went well, with no problems.

after restart then the usb modem have placed a folder
on the desktop window, called highlink.. and Trisquel is asking
what to do with this highlink program.
the highlink is a connection and modem manager from the isp.

this is my friends computer, and he will not have the isp's software installed on his computer, the highlink is not even necessary to have a functional internet-connection.

the question is: how can he have a internet-connection
without installing the highlink software.

we have tried to install, Trisquel again and again four times
but the problem persist.

we also tried to:
"type in terminal as root (or sudo the commands):
sudo lsusb -v | less

Get the vendor and product ID from the result of the above command.

Like: Bus 003 Device 003: ID 12xx:15xx Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

Note the two references after ID (12xx and 15xx)

Now append this line in /etc/modules:
usbserial vendor=0x12xx product=0x15xx

(to edit type "nano /etc/modules" as root, add the lines, hit ctrl+o to write the file (save) and ctrl+x to close nano.)

Reboot your computer and your done.
Set up a new mobile broadband connection and your online"

but the problem persist anyway..

what can we do, to stop this isp software from installing.

and gain a internet-connection.

it have worked for tre years in Trisquel seven without the
isp highlink-software ever shown itself.

i seems that Trisquel is seeing the usb modem as a harddrive
with some kind of "autorun"

what can we do to gain a no nonsens internet-connection
with this usb modem.. without the isp software.

ps: we are nob's 8O)

Magic Banana

I am a member!

Joined: 07/24/2010

i seems that Trisquel is seeing the usb modem as a harddrive with some kind of "autorun"

Caja is the default file manager. I assume it is what you use. If so, have you tried checking the box "Never prompt or start program on media insertion" in the "Media" tab of Caja's "Preferences", which you can access from the "Edit" menu? If that works, you can then try finer settings.

Stallman rules
Joined: 08/10/2019

Thank you so much Magic Banana 8O)

You assumed right, my friend is using caja.

The problem is that he apparently haven't the
time to try your solution.

I will wait for him, to try your solution.

sorry, and best regards

Stallman rules
Joined: 08/10/2019

We are Back.. again 8O)

My friend where moving and at the same time
he was a little sick. 8O(

But yesterday night we tried again, from scratch.

Installed Trisquel 8 the graphic way again..

My friend made sure that caja was configured not to
run anything. just like Magic banana wrote.

Then plugged the huawei e3372 usb 4G modem in
and updated Trisquel, about 400 mb, all went well.

When Trisquel, at the end of the update and installation
ask to; restart ore restart later, he chose to restart later.

he tok the modem out, and shut down Trisquel.

Then started Trisquel again, and all looked nice.
he checked, that caja was set, not to run anything..
when a media where inserted, just like Magic banana wrote.

Then he plugged the usb 4G modem in the machine..

And.. lo and behold.. the HiLink folder where back
on the desktop again, and no internet connection..
nothing.. zip zero...

we are now stranded at the shores of proprietary
software, made by the isp; Telia, sitting on a usb
4G huawei 3372 modem.. Just waiting to unleash
itself in the Libre TrisQuel...

by the way, the 4G modem is blinking light blue
witch indicate that there is a 4G connection..

we then configured a connection in network-connections..
new connection, mobile broadband, country, isp
and apn and so on.

but.. nothing happens ...

took the modem out and plugged it in a different usb inlet..
restarted.. nothing... shut the machine down.. started up again..

nothing.. happens..

what is going on with this usb 4G modem..?

fore tree years it has worked perfectly in Trisquel 7..
just out of the box without any HiLink software, ever
showed itself in Trisquel 7.

but now here in an updated Trisquel 8 it will not allow
any connection without installing the isp's proprietary
software, called HiLink.. represented by a folder
on the desktop named HiLink.

My friend is now changing the harddisk in the Libre T400
back to the Trisquel 7 harddisk, so he can tjek he's e-mails
and surf like a normal person.. with the same usb 4G huawei
3372 mobile modem.. witch by the way is working perfectly
without the HiLink software ever showing itself..

what is going on.. will he ever be surfing with Trisquel 8

Can anybody help him.. please do. 8O)

Magic Banana

I am a member!

Joined: 07/24/2010

As always with hardware, something easy that is worth trying is an update of the kernel. Trisquel 8 ships with Linux 4.4 but you can install, from its repository, the package "linux-image-generic-hwe-8.0" to get a 4.15 image. You can have version 4.19 or even 5.2 following the instructions on

You could even try Trisquel 7's kernel... although it is not patched anymore (security risks):

You need to reboot on the newly installed kernel (the newest version is the default) before testing again.

Joined: 08/19/2019

A response from me AT LAST*:

Thanks a lot, Magic Banana. To questions now:

A: What is the reason I have to update the kernel - because when I install the original Trisquel 8, I can enter WWW. Not after updates.

B: Are you asking me to downgrade to the original Trisquel 8 ISO kernel?

- Gratefully, Falken

*: Due to the combination of extraordinary busyness/pressure in life and long-lasting difficulties entering the forum. The latter now "fixed" by deactivating various security.

Magic Banana

I am a member!

Joined: 07/24/2010

Keeping an online system without updates is risky: updates bring security fixes. That is why I suggest to first try to *up*grade the kernel.

Now, if Trisquel 7 was properly driving your modem, that is certainly thanks to its kernel: drivers are in the kernel. So, if newer versions of the kernel do not solve your problem and if you are willing to use an unmaintained kernel despite the security risks, then there is the .deb package I linked to. As for any .deb, if double-clicking on it does not propose the installation, then install the "gdebi" package, in Trisquel's repository, and try again. The .deb in question contains Trisquel 7's kernel image with the last updates it received, months ago. Again: it will not receive any more update. Ever. And it contains known vulnerabilities.

Joined: 08/19/2019

(Yes, I'm the friend mentioned by Stallman rules). :¤)

Joined: 08/19/2019

Thanks a lot.

I'll be grateful if you or others can tell:

1: How do I sustain the upgrading of the kernel?

1½: More specific: When I first time go online and upgrade, will my Trisquel then keep/sustain the kernel I already updated to?

2: Does the old kernel in Trisquel 7 (T7) have a driver that the online-updated T8 does not have after the first online update after DVD installation?

3: The original Trisquel installation (from dvd) was able to see that my modem is a modem, not a usb harddiskdoes an updated T8 online-updated version see it as the latter?

3½: More specific: Why does the kernel (Linux kernel and Trisquel) suddenly see the USB 4G modem as if it is a harddisk?

4: Can anyone provide a link that tells Trisquel and the kernel that my proprietary 4G USB modem is a modem, not a USB harddisk?

Magic Banana

I am a member!

Joined: 07/24/2010

As I wrote in you can install the package "linux-image-generic-hwe-8.0" to get version 4.15 of the kernel. You can, for instance, use the "Synaptic Package Manager" (by default in Trisquel) to do so. And again, "you can have version 4.19 or even 5.2 following the instructions on".

With those versions, you will automatically be notified when security updates are available and you will be invited to install them in one click.

I do not know precisely what is the problem with the support of your modem. Neither why it is seen as a hard disk. But upgrading the kernel may bring a solution. If not, you can try downgrading to Trisquel 7's kernel. Indeed, as I have already written as well, "if Trisquel 7 was properly driving your modem, that is certainly thanks to its kernel: drivers are in the kernel". But, again, you will never get any update, not even to fix known vulnerabilities. Because they are not backported to this older version of the kernel.

When you write about "the original Trisquel installation (from dvd)", are you referring to a Trisquel 7 or a Trisquel 8 live DVD?

Joined: 08/19/2019

Addition to question 4: Can anyone provide a link or script (...).