Why does installing Trisquel 7 updates cancel my sound system?

33 respostas [Última entrada]
Lil Beanie
Desconectado
Joined: 08/17/2017

This doesn't appear to be the first time. But, it is the first time I caught it in time to know where the issue occurred.. I really do not want to overwrite my harddrive again because of some soft switch in the configuration that has been reset...

Any ideas????

Magic Banana

I am a member!

Conectado
Joined: 07/24/2010

I doubt there remain many users of Trisquel 7, who may help you. Trisquel 7's support will end next month: you should upgrade to Trisquel 8. That upgrade may solve your sound problem too.

Lil Beanie
Desconectado
Joined: 08/17/2017

Unfortunately, no. Trisquel 8 was not helpful. 7 is compatible with my computer system. I am ruing the fact that I accepted the suggestion from Trisquel to upgrade yesterday. I really do not want to go through the hassle of wiping and reinstalling my solid state harddrive now. But, without help, that will be my only option.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> 7 is compatible with my
> computer system.

Then Trisquel 8 almost certainly is too.

> I am ruing the fact that I accepted the suggestion from
> Trisquel to upgrade yesterday.

So you tried upgrading and have experienced problems? Chances are that
the problem is not Trisquel 8, but with the process by which you
upgraded.

> But,
> without help, that will be my only option.

I'm happy to help, but that's tough without knowing what specific
problems you are encountering. Here are guesses, based on issues other
users have encountered while upgrading from Trisquel 7 to Trisquel 8.

(1) Make sure that the package "trisquel" is installed. You can install
this package graphically with Synaptic or via the command line with

$ sudo apt install trisquel

See here[1] for information on installing software. If your system is so
broken that you can't even get a terminal open, then instead of logging
into a graphical session type Ctrl+Alt+F1 to get to a TTY. Log in there,
and run "sudo apt install trisquel".

Once Trisquel is installed, reboot. Then, at the login screen, look for
a little icon next to your username. Click on it, and you will get a
dropdown list of all of the desktop environments you have installed. One
of them will be called something similar to "Trisquel" or "GNOME" or
"GNOME Fallback". This was the default desktop environment for Trisquel
7. Another will be called "MATE". This is the default desktop
environment for Trisquel 8, and that is what we want. After selecting
"MATE", log in.

If you have already done all of this and still have problems, we'll need
to you be specific about exactly what those problems are in order to
help you fix them. When describing each problem, tell us
- What did you expect to happen?
- What did you try?
- What happened instead?

[1] https://trisquel.info/en/wiki/installing-updating-and-removing-software

autumnlover
Desconectado
Joined: 02/23/2013

Did the update process included a new version of the Linux kernel, even the minor one? Try to boot using previous version of kernel using GRUB advanced options.

Liberated
Desconectado
Joined: 03/22/2019

Same problem here on Trisquel 8.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> Same problem here on Trisquel 8.

Do you mean sound? If so, can you describe the problem in more detail so
that we can troubleshoot? I just updated my Trisquel 8 system and sound
works fine, so I need to know more about your situation in order to
help.

Masaru Suzuqi
Desconectado
Joined: 06/06/2018

Same problem here on Trisquel 8.

Sasaki
Desconectado
Joined: 08/11/2014

Hi I use both Trisquel 7 and Trisquel 8 and don't experience any problems with sound. I even use those systems for realtime music production.

To help you with the issue you're facing we need more informations about it.
Have you checked your soundcard ? Have you checked sound parameters ? If you use trisquel-mini, I recommend installing the package pavucontrol.
Have you tried with another sound server (e.g package qjackctl) ?

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

@Lil Beanie

If I understand correctly, your sound problems happened after a regular Trisquel 7 update, and that your problems upgrading to Trisquel 8 were a separate issue. Can you confirm whether or not this is the case?

@Lil Beanie, Liberated, Masaru Suzuqi

Can all three of you run

$ uname -r

and copy/paste the results here? autumnlover could be right that a kernel upgrade caused the problem, so I want to see if you all three of you are using the same kernel. I would expect Trisquel 7 to have a different kernel from Trisquel 8.

@Sasaki

Do you use Pulseaudio on any of your systems, or just ALSA+JACK?

Liberated
Desconectado
Joined: 03/22/2019

4.4.0-143-generic

Magic Banana

I am a member!

Conectado
Joined: 07/24/2010

That is Trisquel 8's default kernel, with all security/bug-fix updates installed. It works great here. Have you tried booting an older kernel, from GRUB's "Advanced options for Trisquel" (or something like that, in the menu after the computer powers on but before an operating system starts)?

Liberated
Desconectado
Joined: 03/22/2019

Yes, the other 2 kernels (4.4.0-142-generic and 4.4.0-141-generic) did not fix the problem.

Magic Banana

I am a member!

Conectado
Joined: 07/24/2010

In 'alsamixer' (to execute in a terminal), is the proper sound card selected (with F6) and are the relevant channels (Master/Speaker/...) unmuted and with a sufficient volume?

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> Yes, the other 2 kernels (4.4.0-142-generic and 4.4.0-141-generic) did
> not fix the problem.

I'm going to assume that "the problem" is that you have no sound. If the
problem is more specific than that then let me know. I'm also assuming
that you are using MATE, the default Trisquel desktop environment, and
that you have not uninstalled Pulseaudio or installed JACK. Let me know
if any of these assumptions is incorrect.

Here are some things to try:

First run

$ aplay -l
$ arecord -l
$ lspci | grep Audio
$ sudo lshw | grep -A 5 multimedia

and copy/paste the output of those four commands here.

Next, go to Control Center -> Sound, and go to the "Hardware" tab. You
should see at least one sound device. For each device you see, click
"Test Speakers" and test all of the output channels. If you are using a
laptop, try this both with and without headphones. See which devices can
and cannot produce sound.

Next, start playing some music or something through vlc or mpv (not
Abrowser) and while that's going run

$ alsamixer

(You might have to install it first.) alsamixer exposes lower-level
settings for your sound cards than MATE's volume preferences. Here are
the basic controls
- Left/Right to switch between faders
- Up/Down to adjust a fader
- M to mute/unmute a fader
- F6 to switch sound cards

Unmute and turn up every fader for every sound card until you get sound
or run out of faders to try.

Report back the results of trying these things. The more detailed you
can be the better. Hopefully that will give us some clues as to what the
problem is.

Liberated
Desconectado
Joined: 03/22/2019

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC3227 Analog [ALC3227 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC3227 Analog [ALC3227 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

$ lspci | grep Audio
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)

$ sudo lshw | grep -A 5 multimedia
*-multimedia:0
description: Audio device
product: Haswell-ULT HD Audio Controller
vendor: Intel Corporation
physical id: 3
bus info: pci@0000:00:03.0
--
*-multimedia:1
description: Audio device
product: 8 Series HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0

Testing the speakers and headphones did result in sound, both with the speakers and the headphones.

Turning up the faders while playing music did not fix the problem.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> Testing the speakers and headphones did result in sound, both with the
> speakers and the headphones.
>
> Turning up the faders while playing music did not fix the problem.

Okay, it sounds like everything is fine between ALSA and the sound card,
in which case the problem is higher-level than ALSA.

Start playing music in VLC, and go back to Control Center -> Sound, and
this time go to the "Applications" tab and see if VLC is listed.

Then, in VLC, go to Tools -> Preferences, go to the "Audio" tab, change
"Output module" to "ALSA audio output". See if you get sound or if
anything changes in the "Applications" tab of your Sound settings. If
there is no sound and no change, try restarting VLC.

Liberated
Desconectado
Joined: 03/22/2019

Performing those steps did not result in any sound.

I should add that when I start the computer and the login screen shows up, the sound that is supposed to play still plays.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> I should add that when I start the computer and the login screen shows up,
> the sound that is supposed to play still plays.

Hm. If you log into a guest session do you have sound?

Liberated
Desconectado
Joined: 03/22/2019

Yes, sound works perfectly in a guest session.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> Yes, sound works perfectly in a guest session.

That means that the problem is specific to your user's configuration. It
sounds like ALSA works, since you got sound when testing your speakers
in Sound settings. (I have since learned that a faster way to do this
would have been to run "speaker-test" in a terminal.) This leads me to
suspect that the problem is with your pulseaudio configuration. What I
would do, is run

$ sudo apt purge pulseaudio && sudo apt install pulseaudio

The difference between "apt purge" and "apt remove" is that "remove"
uninstalls the program but leaves your configuration files, whereas
"purge" removes both the program and configuration files. This way, when
you reinstall pulseaudio you will get fresh configuration files which
should be the same as your Guest user.

If this doesn't work, then the configuration problem is with something
other than pulseaudio and we'll take it from there. In my experience
though, pulseaudio is the most common culprit. Removing pulseaudio
entirely would probably fix sound too, but Firefox and
Firefox-derivatives like Abrowser and Icecat require pulseaudio for
sound, so we're stuck with it. Hopefully returning to the default
configuration will be enough.

Liberated
Desconectado
Joined: 03/22/2019

Unfortunately, running that command as well as running both of those apt commands separately did not fix the configuration problem.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> Unfortunately, running that command as well as running both of those apt
> commands separately did not fix the configuration problem.

I forgot to mention that you'll need to reboot next. Have you already
done that?

Magic Banana

I am a member!

Conectado
Joined: 07/24/2010

The problem is specific to the *user*. 'apt purge' removes *system* configuration files. It does not remove ~/.config/pulse (that is a folder named "pulse" in a hidden folder named ".config" in your home folder). I would try to remove it.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> 'apt purge' removes *system* configuration files.

My bad. Thanks for the correction.

@Liberated
Remove the folder Magic Banana mentions with

$ rm -rf ~/.config/pulse

and then log out and back in again.

Liberated
Desconectado
Joined: 03/22/2019

Sound still does not work after deleting that folder.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> Sound still does not work after deleting that folder.

Then the problem might be unrelated to pulseaudio. To confirm though,
can you run

$ sudo apt remove pulseaudio

reboot, and see if sound works (in vlc or something, not your browser).

Then reinstall pulseaudio with

$ sudo apt install pulseaudio

If sound still does not work while pulseaudio is uninstalled, that will
confirm that the problem is somewhere else.

After you do that, let's temporarily rename your .config folder

$ mv ~/.config ~/.config-backup

and reboot again. See if sound works, and then restore your .config
folder

$ mv ~/.config-backup ~/.config

If sound worked, that confirms that *something* in .config is the
problem, and our next step will be to narrow down with file(s) it is.

Liberated
Desconectado
Joined: 03/22/2019

The problem seems to have resolved itself after restarting the computer, having deleted the folder a few reboots before that, however. Most likely had something to do with that folder, as you said.

Thank you again for all of the help! I really appreciate it!

Libreshop
Desconectado
Joined: 10/27/2018

Do you have a spare usb-drive to install live-setup?
So instead of formatting your main drive, you can check if the problem is only with your os or kernel or not. If you don't mind, try with Trisquel 8 and Mini version, or with any other distro your comfortable with. (maybe even Ubuntu, even if it's not endorsed by Free community, so you can check if it's free/non-free kernel dependent?

Liberated
Desconectado
Joined: 03/22/2019

Sound works fine on a Trisquel 8 Live USB.

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

@Liberated, I'm glad everything's working now.

@Lil Beanie, If you are still having trouble with sound, can you try

$ rm -rf ~/.config/pulse

and see if the problem goes away as it did for Liberated?

Liberated
Desconectado
Joined: 03/22/2019

I just realized that the volume button/slider which is usually next to the network button on the bottom panel is missing. Most likely due to a change I made in trying to fix the problem.

Any way to bring it back?

chaosmonk

I am a member!

I am a translator!

Desconectado
Joined: 07/07/2017

> I just realized that the volume button/slider which is usually next to the
> network button on the bottom panel is missing.

It's possible that this applet had pulseaudio as a dependency, got
uninstalled when we removed pulseaudio.

Run

$ sudo apt install trisquel

to install the "trisquel" metapackage, which contains all components of
the default desktop environment.

SuperTramp83

I am a translator!

Desconectado
Joined: 10/31/2014

or install another plugin.. There are others besides teh pulseaudio plugin..