WiFi connection problem after installing Trisquel 7

6 respostas [Última entrada]
Piriponzolo
Desconectado
Joined: 02/19/2016

Hi!
After installing Trisquel 7 I have WIFi connection problem with my Huawei USB 3G modem, because I always read the following:

"Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/9' failed in libnm-glib"

How can I solve the problem? Thanks since now. Piriponzolo

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010

Where do you read that error? What is the output of 'lsusb' (to be executed in terminal when the device is plugged)?

Piriponzolo
Desconectado
Joined: 02/19/2016

Hello, Magic Banana and thank you for the reply. I see that error up at right.
The output of 'lsusb' executed in terminal with plugged device is:

Bus 001 Device 004: ID 12d1: 1506 Huawei Technologies Co., Ltd Modem/Networkcard
Bus 001 Device 001: ID 1d6b: 0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b: 0001 Linux Foundation 1.1 root hub

Thanks again for the help. Have a nice evening

Magic Banana

I am a member!

Desconectado
Joined: 07/24/2010
Piriponzolo
Desconectado
Joined: 02/19/2016

Already tried, it doesn't work!

GNUbahn
Desconectado
Joined: 02/18/2016

I don't know if this is related but after the initial install and later after a grub edit Trisquel didn't recognise my wifi (as well as my mouse and BT). By suggestion of Magic_banana I updated the kernel and problem was solved. I chose a manual install: https://trisquel.info/en/wiki/update-linux-libre-kernel

Piriponzolo
Desconectado
Joined: 02/19/2016

Hello to everyone. I solved my WiFi connection problem with the Thinkpenguin USB adapter. Have a nice day.