Desktop+Etonia 9 Hanging, sleeping and crashing all the time

Categoría:informe de erro
Asignado:Sen asignar

Hello. I don't understand what's going on.

I bought this computer to keep hundreds of VMs working all the time a lot of 6-TB drives being mounted and things being done with them - erasing processes etc. But too often I face just hanging and/or sudden falling asleep without reason - with black screen or not. RAM is empty, CPU is not busy (below 10%), yet screen, mouse and keyboard hang and absolutely nothing of "ctrl+alt+anything" helps. Absolutely nothing works except hard reboot.

In BIOS it never hangs nor crashes or fall asleep for no reason. Nor it does in LUKS screen. Only in working Etonia 9.

Once I got black screen "failed to idle channel" issue when redirected the drive to open the video in VM and then after redirecting the drive back - in host:
In my case were 4 and 5 channels not found. Ctrl-Alt-Delete worked as reboot everything.

I must say I always had a lot of "not found channel" writings in black screen before boot but videos were still running somehow.

I also have problem with no sound in virt-manager guests. I tried this: it did not help.

Absolutely none of these problems I ever noticed with old laptops, only with this new Desktop. Please tell me what to do and why it is going on. Thank you.

Expected: working day and night as server with dozens of VM running and dozens of drives mounted. Without sudden hangs, sleeps and related.

Intel X-series CPU 8/16 cores
Trisquel Etonia 9 installed on 6TB HDD
Nividia GFORCE GT 710
A lot of other 6TB HDD

(I especially experience hang problems with mounting more than two 6Tb HDD at once)

Ven, 09/25/2020 - 22:38
Título:Desktop+Etonia 9 Hanging, sleeping and crushing all the time» Desktop+Etonia 9 Hanging, sleeping and crashing all the time

Firstly One issue, one problem. So open a new issue for your problem with mounting more than one HDD. Specify what sort of connection (SATA 3 or USB) you're mounting them over. Also specify the exact CPU processor model, how you are mounting the HDDs (GUI/mount command),,

Your sound problem with virt-manager is documented upstream as 'working as designed' here .

As to your freezes. First update your machine sometime after 2020-09-28 to fetch the latest kernel update and retest. Then, which kernel are you using (the output of 'uname -a')? What sort of HDD connection (SATA 3 or USB) are you using? Have you turned off any Power Management sleep settings? What is the arrangement of any internal HDDs - e.g. software RAID 0, 1 or 5 and how many together? If you are using USB connections - what makes you think with 10Gbps of USB 3.1 you're going to have much satisfaction connecting 'dozens' of 6TB drives. What *exactly* are your VMs doing with these drives? Have you enabled VT-x in the BIOS? What sort of VM e.g. KVM/QEMU are you using? Has this machine ever worked reliably for you under any O/S? You say 'new Desktop' but is it second user? Does the machine run fine if you don't start any VMs? If so, how many VMs do you have to start for the problem to appear? And do they have to have VNC displays actively displayed on the desktop?

Please ensure you answer all the above.

Sáb, 09/26/2020 - 11:46
Estado:active» needs more info
Mér, 09/30/2020 - 10:35

Hello. Thanks for the answer.

Intel® Core™ i7-7820X X-series Processor. I think it is here:

Two 6-TB SATA, five different-TB drives via USB, one several GB USB stick (but there are no problems with the stick). But they are mostly not all mounted at once. Problems start when I mount both SATAs and 1-2 drives, especially when all those I mount are 6-TB. I have Trisquel on one of those SATA running - on all 6TB.

I use only GUI mount. I have Mate desktop Etonia 9. For mounting I use Gnome-disk-utility and a file manager.

I use last kernel that I got from these repositories that I have in my sources.list and updated almost every day (when it does not freeze or poweroff) via command:
sudo apt update && sudo apt full-upgrade

"What is the arrangement of any internal HDDs - e.g. software RAID 0, 1 or 5 and how many together? If you are using USB connections - what makes you think with 10Gbps of USB 3.1 you're going to have much satisfaction connecting 'dozens' of 6TB drives."

Sorry I did not fully understand the RAID thing and what should I do with my linux to find the answer (what command to execute in terminal to find the DAID for every drive etc). I also have no idea whether and why any USB works ok or not. It worked ok with 1-2 USB 1-2TB drives with linux laptops. Now I start having problems when OS+another 6TB SATA (=12TB) are mounted already and I try to mount 6TB USB.

I use qemu-kvm that I got from Etonia repositories via:

sudo apt install qemu-kvm

and update it every day or every day when it is neither freeze nor powered off.

Virt-manager I built from source via git clone.

I had no problems with neither qemu kvm nor virt-manager on laptops ever with Trisquel, Debian and Pure OS as hosts and different Linux and Windows as guests. But at laptops since they have very little RAM, I used only one VM at once without redirecting anything into it.

What I exactly do with VM is redirecting 1,2,4 or 6 TB USB drives there (since as I found virt-manager can't redirect SATA) and executing processes with those drives. I also build software, but building software in terminal does not cause freeze even when taking 100% CPU power.

Yes I have virtualization at CPU enabled plus I successfully configured nested Virtualization so that I successfully run VM inside VM via qemu-kvm.

What I completely do not understand is how they freeze when RAM is almost free and CPU is mostly not too busy. I noticed one of the Cores is usually 100% busy on host when even one VM is running (often with other VM inside it). The 8th Core. I wonder if the freezes are CPU-related or GPU-related.

Right now I have my Desktop again freeze. It freezes after I started bleachbit at host while running VMs to cleanse its RAM to free it (because I believed it would help not freeze longer - I have important process running in one of VM that I know needs about a week to accomplish). And one 2TB drive is mounted and redirected to that VM. Other 2 2TB drives are mounted at host. No 6TB is mounted. But as I ran bleachbit it froze. Important detail: bleachbit was not cleansing anything when froze, it was just started as a program and it's GUI got open - and at the moment I was using the mouse to check the settings, it froze. CPU was up to 100% busy only on host, guests had CPU 13% busy. RAM is gigantic so it was everywhere free. Now I can't use mouse, keyboard or anything, but I hope my process is still running and maybe after a week of running it will end. So I wonder is my process also froze and I should hard reboot or is it still running inside and I should wait for a week for it to end and then hard reboot?

There are no other users, only root and me on host. Maybe qemu-kvm software created some user too.

I have only 2 VM for now. I need actually one VM to start having problems, while problems may not start even with 2 when no additional TB+ drive is mounted. I definitely start having freeze problems with 2-3 6-TB drives moubted at once (including linux running on one of them) - 2 of them SATA. Even without ANY VM and with almost no software on host running - only file manager 1-2 windows, gnome disks 1 window and terminal 1-3 windows. This is enough to freeze. First it starts freezing for several seconds and then going again, then after some time it freezes forever.

No, they do not need VNC display active to freeze.

I never tried yet to run more than 2 VM (only one of them has VM inside VM). When without SATAs nor drives mounted they ran good - even with software being built in terminal. But as I started to mount and redirect my drives into them they started to freeze.

Thanks for the link with sound problem addressed. It is strange that in laptops everything worked out of the box.

As for Power management I configured it to never sleep when on power (battery does not exist at Desktop) and I noticed it usually never sleeps when screen is not locked, when it is locked it sleeps very quickly. But sometimes it just ended up with black screen even when not locked - just as a part of a freeze.

Dom, 10/04/2020 - 02:25

Have you tested your RAM? Trisquel's repository includes "memtest86+".

Lun, 10/05/2020 - 15:10

Thanks, I installed memt6est86+ but can't figure out how to use it. I have 64GB RAM and I never had it full busy in System Monitor, plus always cleanse it with sudo bleachbit (which though gives errors).

Update: I successfully got sound in guests by putting this into /usr/bin/kvm:

exec qemu-system-x86_64 -enable-kvm "$@"

I still have a lot of problems with freeze. It always come unexpected and unprepared so I lose my work. It is connected to mounting a lot of huge drives and doing things with them such as erasing formatting etc.

All running VM work great till I try to mount a big drive.

I have another problem with VLC player. Sometimes when I open a video in VLC it tries to go full screen and at that moment everything except running VM gets shut down and I see login screen or just freeze everything so that only hard reboot helps. I do not have these problems in debian guests only in trisquel 9 host.

Ven, 10/23/2020 - 00:25
Estado:needs more info» active

Sorry I did not notice it was still "needs info status" and that I could change it long ago. Please tell what else info I might provide if still needed. Thank you.

Update. Today I had it hung with 2 USB drives - one 2TB and other 1TB - being mounted into one VM inside other VM, while 2 first-party VM were running.

I also have a lot of problems with being redirected to login screen lately - only in host machine Trisquel 9. Out of all sudden. I was just working in one of VMs and host suddenly forced me into login screen. I never work on host. I just update and upgrade it everyday, mount drives and run virt-manager. Nothing more.

Mar, 01/18/2022 - 23:42
Estado:active» needs more info

I would use the default kernel, as it will follow the upstream one.
Installing linux-libre you will get newer kernels, but many "bloat" modules are stripped from that kernel.

Using the trisquel shipped kernels you have a known environment, as it will be more like the ubuntu ones, and you'll get a far stable one.

If you are looking for newer kernels you might want to upgrade to trisquel 10, which shippes 5.4 up to 5.13.
The issue sounds to me like a hardware issue, that could be kernel related, so please to to default to trisquel's kernels and see performance there.


Sáb, 01/29/2022 - 19:50

Hello again,

is there any other news on this issue?
is this still valid?

If not, this issue will be closed in about a week from now.

Sáb, 02/05/2022 - 09:10
Estado:needs more info» closed